summaryrefslogtreecommitdiff
path: root/dev-libs/libwbxml/libwbxml-0.11.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-libs/libwbxml/libwbxml-0.11.6.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-libs/libwbxml/libwbxml-0.11.6.ebuild')
-rw-r--r--dev-libs/libwbxml/libwbxml-0.11.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libwbxml/libwbxml-0.11.6.ebuild b/dev-libs/libwbxml/libwbxml-0.11.6.ebuild
new file mode 100644
index 000000000000..5837b81e8f4f
--- /dev/null
+++ b/dev-libs/libwbxml/libwbxml-0.11.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Library and tools to parse, encode and handle WBXML documents"
+HOMEPAGE="https://github.com/libwbxml/libwbxml"
+SRC_URI="mirror://sourceforge/libwbxml/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/expat
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS=( BUGS ChangeLog README References THANKS TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_INSTALL_DOC=OFF
+ -DENABLE_UNIT_TEST=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}