summaryrefslogtreecommitdiff
path: root/dev-libs/libvterm/libvterm-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 07:10:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 07:10:13 +0100
commit42ff81a7480d9bba317b42fcca03b46da2a622ce (patch)
tree5a0ccbe2b71a4ec6c160b568160999a6afe316de /dev-libs/libvterm/libvterm-0.3.ebuild
parent290844d409ace33d948956aec3c542ea6f4a7b13 (diff)
gentoo auto-resync : 01:10:2022 - 07:10:12
Diffstat (limited to 'dev-libs/libvterm/libvterm-0.3.ebuild')
-rw-r--r--dev-libs/libvterm/libvterm-0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libvterm/libvterm-0.3.ebuild b/dev-libs/libvterm/libvterm-0.3.ebuild
new file mode 100644
index 000000000000..5011f386127d
--- /dev/null
+++ b/dev-libs/libvterm/libvterm-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="https://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="https://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/libtool
+"
+
+src_compile() {
+ emake VERBOSE=1 PREFIX="${EPREFIX}"/usr LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake VERBOSE=1 DESTDIR="${D}" PREFIX="${EPREFIX}"/usr LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+
+ find "${ED}" -name '*.la' -delete || die "Failed to prune libtool files"
+ find "${ED}" -name '*.a' -delete || die
+}