summaryrefslogtreecommitdiff
path: root/dev-libs/libvterm/libvterm-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-17 22:43:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-17 22:43:15 +0000
commit52f895faaaf01579a8d9528cafec20bf2c873f5c (patch)
treed552df2a24a2e21fd08b08caef93840452b9889c /dev-libs/libvterm/libvterm-0.1.3.ebuild
parent0704956f7256f1f618cc5e03af2c1dbd0e83dbc5 (diff)
gentoo resync : 17.01.2010
Diffstat (limited to 'dev-libs/libvterm/libvterm-0.1.3.ebuild')
-rw-r--r--dev-libs/libvterm/libvterm-0.1.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libvterm/libvterm-0.1.3.ebuild b/dev-libs/libvterm/libvterm-0.1.3.ebuild
new file mode 100644
index 000000000000..dacba680fa78
--- /dev/null
+++ b/dev-libs/libvterm/libvterm-0.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="http://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+DEPEND=""
+RDEPEND="!dev-libs/libvterm-neovim"
+
+src_compile() {
+ append-cflags -fPIC
+ emake VERBOSE=1 PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake \
+ VERBOSE=1 \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
+}