summaryrefslogtreecommitdiff
path: root/dev-libs/libvterm/libvterm-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
commitda491770b9ba5f179e18db461c49cb6f1ccf0e1f (patch)
treed3e34a8bd906741ab18cf69d8d4f732853e26ade /dev-libs/libvterm/libvterm-0.1.1.ebuild
parentad6182343997a405079870a2fe91c4e0c6b94595 (diff)
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'dev-libs/libvterm/libvterm-0.1.1.ebuild')
-rw-r--r--dev-libs/libvterm/libvterm-0.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libvterm/libvterm-0.1.1.ebuild b/dev-libs/libvterm/libvterm-0.1.1.ebuild
new file mode 100644
index 000000000000..a9f83554b9e2
--- /dev/null
+++ b/dev-libs/libvterm/libvterm-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="https://launchpad.net/${PN}/trunk/v$(ver_cut 1-2)/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+DEPEND=""
+RDEPEND="!dev-libs/libvterm-neovim"
+
+src_compile() {
+ append-cflags -fPIC
+ emake VERBOSE=1 PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake \
+ VERBOSE=1 \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
+}