summaryrefslogtreecommitdiff
path: root/dev-libs/libverto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libverto
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libverto')
-rw-r--r--dev-libs/libverto/Manifest6
-rw-r--r--dev-libs/libverto/libverto-0.2.5-r1.ebuild51
-rw-r--r--dev-libs/libverto/libverto-0.2.5.ebuild51
-rw-r--r--dev-libs/libverto/libverto-0.2.6.ebuild51
-rw-r--r--dev-libs/libverto/metadata.xml15
5 files changed, 174 insertions, 0 deletions
diff --git a/dev-libs/libverto/Manifest b/dev-libs/libverto/Manifest
new file mode 100644
index 000000000000..ef00ddc0b432
--- /dev/null
+++ b/dev-libs/libverto/Manifest
@@ -0,0 +1,6 @@
+DIST libverto-0.2.5.tar.gz 349722 BLAKE2B fd46b1fd1500d4732baa2d461e4b490386ff54efa8a23f06f40048e1624b4698cfedcfda79cc0a21c9a77050baafe8572835f1c0d174873772afe46b199a6294 SHA512 d57a7f86e714d3fbed391984de3356d8a2769f846985769c1be7d881647c1be95a5fc6a82bba1660ef3241aa1a40150b5e005af6f35dc32473facfdea49c556e
+DIST libverto-0.2.6.tar.gz 352690 BLAKE2B b1610fd7c64fff31d46640ef10fd895f9ce2f0d1d4fd4ac205f2ec5f519f695c8ec82da8b9539c28c0d087bfd3664101192010ee59a9632f09b3ed92e52c1054 SHA512 aa8d047501d28741f2f8185fc4a0ef6dc4b99dbe69b583c40cd4c0afc97db4dd0a928d9ec23861fff61651e9ac82e52da9473b8e62ccc11a91e5e5c6b41dfd3b
+EBUILD libverto-0.2.5-r1.ebuild 1499 BLAKE2B a97d265fcde7e10561922e65cd82e996a1db10b9610343bf98eca138220770ea3d171a98ea9fa0c198f4748219f96e3faaf73171c8cd73e41178cb234bf48bb1 SHA512 b0857b0ad06148bf06d019cdb333bdb00844fa183dbe80a317b945330ed3fdf77dcc46bbad247a5bf7055e2abb0d7560450b9f707e6ff6d56013242f700df34e
+EBUILD libverto-0.2.5.ebuild 1370 BLAKE2B 90b0ceacf5ad29c383436ef3bf297edf9ea185bf0912727ad9f5509dd40c0f7f8b5e46c36c2d9667924617211f6e0064946283a591b0ce085abad17e6bd8e8ed SHA512 322710aac677120e167565e02ed2b6685cf88338ca9d28767c0181fba68de44f78f20dc15571f62ff98ec81775c210931b3ed543cd427ffaaf3a4aa8576c5fe3
+EBUILD libverto-0.2.6.ebuild 1509 BLAKE2B fc4a2ae5eb631f867e0cad789fe6052abc4096f776a3774eb622dbc43f33a1d3dc944df16113cf50878fb06237e430462518b3ea8420110f061f34e1f0b89af2 SHA512 0e33abd39d5fe51f523b3a2739a2b0be8126eafe3d8aa048a343d10545bc53b53c6adab93f9012616c4199c3f3e2ff7f55b4996716656eb514edd65caf776544
+MISC metadata.xml 1080 BLAKE2B cb37ba132016891f547bbf860b3353348b3312d770e220b6cd6cadabbdaea8c272c0b66a391f7a74de7ca0927be2d0f4939b7238b5966d553b5a5b834df93bd6 SHA512 88399edcdaa1d9055b6990605fe3bd1a753eac2ffa3b10ccea88a7385323b9de9f123a0032d19493f27603968fa8d07d29aa09f4f0f21ab5998f0ba2af2e4c00
diff --git a/dev-libs/libverto/libverto-0.2.5-r1.ebuild b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..66e4198d03c0
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib-minimal
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ libev? ( >=dev-libs/libev-4.15[${MULTILIB_USEDEP}] )
+ libevent? ( >=dev-libs/libevent-2.0.21[${MULTILIB_USEDEP}] )
+ tevent? ( >=sys-libs/tevent-0.9.19[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+ use static-libs || prune_libtool_files --all
+}
diff --git a/dev-libs/libverto/libverto-0.2.5.ebuild b/dev-libs/libverto/libverto-0.2.5.ebuild
new file mode 100644
index 000000000000..9e2921bdff40
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.29 )
+ libev? ( >=dev-libs/libev-4.11 )
+ libevent? ( >=dev-libs/libevent-2.0 )
+ tevent? ( sys-libs/tevent )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+src_configure() {
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}
diff --git a/dev-libs/libverto/libverto-0.2.6.ebuild b/dev-libs/libverto/libverto-0.2.6.ebuild
new file mode 100644
index 000000000000..7e7972bdcb53
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib-minimal
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ libev? ( >=dev-libs/libev-4.15[${MULTILIB_USEDEP}] )
+ libevent? ( >=dev-libs/libevent-2.0.21[${MULTILIB_USEDEP}] )
+ tevent? ( >=sys-libs/tevent-0.9.19[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+ use static-libs || prune_libtool_files --all
+}
diff --git a/dev-libs/libverto/metadata.xml b/dev-libs/libverto/metadata.xml
new file mode 100644
index 000000000000..24304b1cca36
--- /dev/null
+++ b/dev-libs/libverto/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription lang="en">Many applications and libraries are unable to write asynchronous code because they are unable to pick an event loop. This is particularly true of libraries who want to be useful to many applications who use loops that do not integrate with one another or which use home-grown loops. libverto provides a loop-neutral async api which allows the library to expose asynchronous interfaces and offload the choice of the main loop to the application.</longdescription>
+<maintainer type="person">
+ <email>eras@gentoo.org</email>
+ <name>Eray Aslan</name>
+</maintainer>
+<use>
+ <flag name="glib">Support event loops using <pkg>dev-libs/glib</pkg></flag>
+ <flag name="libev">Support event loops using <pkg>dev-libs/libev</pkg></flag>
+ <flag name="libevent">Support event loops using <pkg>dev-libs/libevent</pkg></flag>
+ <flag name="tevent">Support event loops using <pkg>sys-libs/tevent</pkg></flag>
+</use>
+</pkgmetadata>