summaryrefslogtreecommitdiff
path: root/dev-libs/libvarlink/libvarlink-19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-libs/libvarlink/libvarlink-19.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-libs/libvarlink/libvarlink-19.ebuild')
-rw-r--r--dev-libs/libvarlink/libvarlink-19.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libvarlink/libvarlink-19.ebuild b/dev-libs/libvarlink/libvarlink-19.ebuild
new file mode 100644
index 000000000000..b8c592de9de1
--- /dev/null
+++ b/dev-libs/libvarlink/libvarlink-19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="C implementation of the Varlink protocol and command line tool"
+HOMEPAGE="https://github.com/varlink/libvarlink"
+SRC_URI="https://github.com/varlink/libvarlink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-meson-build.patch" )
+
+src_configure() {
+ local emesonargs=(
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}