summaryrefslogtreecommitdiff
path: root/dev-libs/libutf8proc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-04 04:20:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-04 04:20:30 +0100
commit67717f5ed7e33856e34f632d5f17a5e218401c0a (patch)
tree609008d60c8ff9be5d300757865570d31c29ac0d /dev-libs/libutf8proc
parent71f9cc21aab4168093940b3d2e267444d712bff5 (diff)
gentoo auto-resync : 04:09:2022 - 04:20:30
Diffstat (limited to 'dev-libs/libutf8proc')
-rw-r--r--dev-libs/libutf8proc/Manifest1
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.7.0-r1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/Manifest b/dev-libs/libutf8proc/Manifest
index d15e2f0b5b05..c0df0909e1ac 100644
--- a/dev-libs/libutf8proc/Manifest
+++ b/dev-libs/libutf8proc/Manifest
@@ -1,4 +1,5 @@
DIST libutf8proc-2.7.0.tar.gz 187906 BLAKE2B b2b3dc86ffa38f1d75293455cca22d3c0a0c51c529f154bbeaf40bb8b91bcedbf3955cfa459323db8b00566ce42857391875dac6fd677e36f700e8614767ac25 SHA512 29f7883de13302d609e8755872ed43174e70076e9681b4ac3f9b03e50295c45d9972c193bc81f94ad7e11e2d33a46cad5a30a80873173e6e1ae242101ebb3bed
DIST libutf8proc-EastAsianWidth-14.0.0.xz 70420 BLAKE2B c2fa8ec34ae3cccb532d8ba82dc7ef40d82da2ed2f4bf187ef0df28cecd2e91320e25287e7bc6e7f22ffa6730af7b910b73d69172664235f3236c16a5ffe990f SHA512 5bd11dc8c30d12692d3cbca932c1bda5e19d9b5e99fc9f1a3ff8864e4f0e577769c4e1f91338cad10a468c38b904cf16b99ba44f44b80695cac23fe436f1e24a
+EBUILD libutf8proc-2.7.0-r1.ebuild 1484 BLAKE2B d4bcf35c2896de29170f2f6e772f633aae44e881ec39a0b26e6f8af4725f689dfa700bdbb7e565d0b2b7e44383f610dad7c5840f6febf46ec4c2774c4390b8fe SHA512 1c8391a5747aa714c55a3a609330a117af0be1d0dfc4cc68aab1a7d2a1efd6bddcdc0ed2d49fcf5709fba4e5acf3af1798b1e2854db62a6691c1373bc124510e
EBUILD libutf8proc-2.7.0.ebuild 1456 BLAKE2B ef13c6975061df3b1f76f3900ce4a3dfcbb7ba42b83104414fbd7645452106e64dcd3f2fbeacd6458593c53d2f6d91329a8e936ce0124732c00881e5352214ad SHA512 92c99005775c5d2029ad9a7864bd10ba03d52f6c8cb678075132221d167e7d17a144c771368d62ad4f6bccc1d455a2b53fef2a423a279927d950ee8773bf6c06
MISC metadata.xml 249 BLAKE2B a37da98d387308dab889eab2665b67e4176707f3c115a7a69cb7f4b19f9864b96bc2fe70efa105e627c4b57a7d626f6b23dc2709a225a9debada3356f3cf32a0 SHA512 a5095fb01e05f24583a962e36131b2f02cf2d1dd7a97051200e465ad97db014721de7c1857f5eb736cb0290682e8de833cb4c735f7de8d98cdfae1aed6d3d549
diff --git a/dev-libs/libutf8proc/libutf8proc-2.7.0-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..65c0146e8585
--- /dev/null
+++ b/dev-libs/libutf8proc/libutf8proc-2.7.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit ruby-single toolchain-funcs
+
+DESCRIPTION="A clean C Library for processing UTF-8 Unicode data"
+HOMEPAGE="https://github.com/JuliaStrings/utf8proc"
+SRC_URI="https://github.com/JuliaStrings/${PN#lib}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ cjk? ( https://dev.gentoo.org/~hattya/distfiles/${PN}-EastAsianWidth-14.0.0.xz )"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="cjk static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ =app-i18n/unicode-data-14.0*
+ ${RUBY_DEPS}
+ )"
+S="${WORKDIR}/${P#lib}"
+
+QA_PKGCONFIG_VERSION="$(ver_cut 1).5.0"
+
+src_prepare() {
+ if use cjk; then
+ einfo "Modifying East Asian Ambiguous (A) as wide ..."
+ cp "${WORKDIR}"/${PN}-EastAsianWidth-14.0.0 ${PN#lib}_data.c || die
+ fi
+
+ default
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ prefix="${EPREFIX}/usr" \
+ libdir='$(prefix)'"/$(get_libdir)"
+}
+
+src_test() {
+ cp "${BROOT}"/usr/share/unicode-data/{DerivedCoreProperties,{Normalization,auxiliary/GraphemeBreak}Test}.txt data || die
+
+ emake CC="$(tc-getCC)" check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir='$(prefix)'"/$(get_libdir)" \
+ install
+ use static-libs || find "${ED}" -name '*.a' -delete || die
+}