summaryrefslogtreecommitdiff
path: root/dev-libs/libutf8proc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/libutf8proc/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/libutf8proc/files')
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch21
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch33
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
new file mode 100644
index 000000000000..75e9eaac6b53
--- /dev/null
+++ b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index e3310f7..44c8977 100644
+--- a/Makefile
++++ b/Makefile
+@@ -46,7 +46,7 @@ pkgincludedir=$(includedir:$(prefix)/%=%)
+
+ .PHONY: all clean data update manifest install
+
+-all: libutf8proc.a libutf8proc.$(SHLIB_EXT)
++all: libutf8proc.$(SHLIB_EXT)
+
+ clean:
+ rm -f utf8proc.o libutf8proc.a libutf8proc.$(SHLIB_VERS_EXT) libutf8proc.$(SHLIB_EXT)
+@@ -104,7 +104,6 @@ install: libutf8proc.a libutf8proc.$(SHLIB_EXT) libutf8proc.$(SHLIB_VERS_EXT) li
+ mkdir -m 755 -p $(DESTDIR)$(includedir)
+ $(INSTALL) -m 644 utf8proc.h $(DESTDIR)$(includedir)
+ mkdir -m 755 -p $(DESTDIR)$(libdir)
+- $(INSTALL) -m 644 libutf8proc.a $(DESTDIR)$(libdir)
+ $(INSTALL) -m 755 libutf8proc.$(SHLIB_VERS_EXT) $(DESTDIR)$(libdir)
+ mkdir -m 755 -p $(DESTDIR)$(pkgconfigdir)
+ $(INSTALL) -m 644 libutf8proc.pc $(DESTDIR)$(pkgconfigdir)/libutf8proc.pc
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
new file mode 100644
index 000000000000..5750b43ad5fc
--- /dev/null
+++ b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
@@ -0,0 +1,33 @@
+diff --git a/data/Makefile b/data/Makefile
+index f5d1dd9..60c09e3 100644
+--- a/data/Makefile
++++ b/data/Makefile
+@@ -10,6 +10,7 @@ PERL=perl
+ MAKE=make
+ JULIA=julia
+ CURLFLAGS = --retry 5 --location
++UDATA=/usr/share/unicode-data
+
+ .PHONY: clean
+
+@@ -25,6 +26,7 @@ CharWidths.txt: charwidths.jl EastAsianWidth.txt
+ UNICODE_VERSION=12.0.0
+
+ UnicodeData.txt:
++ cp $(UDATA)/$@ $@
+ $(CURL) $(CURLFLAGS) -o $@ -O http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/UnicodeData.txt
+
+ EastAsianWidth.txt:
+@@ -43,10 +45,10 @@ CaseFolding.txt:
+ $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/CaseFolding.txt
+
+ NormalizationTest.txt:
+- $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/NormalizationTest.txt
++ cp $(UDATA)/$@ $@
+
+ GraphemeBreakTest.txt:
+- $(CURL) $(CURLFLAGS) $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/auxiliary/GraphemeBreakTest.txt | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
++ cat $(UDATA)/auxiliary/$@ | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
+
+ emoji-data.txt:
+ $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://unicode.org/Public/emoji/`echo $(UNICODE_VERSION) | cut -d. -f1-2`/emoji-data.txt