summaryrefslogtreecommitdiff
path: root/dev-libs/libuninum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-libs/libuninum
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-libs/libuninum')
-rw-r--r--dev-libs/libuninum/Manifest3
-rw-r--r--dev-libs/libuninum/libuninum-2.7.ebuild26
-rw-r--r--dev-libs/libuninum/metadata.xml18
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libuninum/Manifest b/dev-libs/libuninum/Manifest
new file mode 100644
index 000000000000..d816cd6336dc
--- /dev/null
+++ b/dev-libs/libuninum/Manifest
@@ -0,0 +1,3 @@
+DIST libuninum-2.7.tar.bz2 276712 BLAKE2B 0894c632d7e9081f35d543895809bcc04fde6da674d4e6adc7cdc914f4bbb257a3e683b381e6496a08b65790731f73315d8263970265a351f40fe504f210c883 SHA512 4536a90b9f34fbabd3cc0560c1ff385063151bc381de51e6ca0253d2a42c2290b92329795b1a12ade305c3cb5757b02fe9d92817829977f50da2e34852936274
+EBUILD libuninum-2.7.ebuild 549 BLAKE2B f22f8a8fa23a623ff85bcd5ee9037ba846792680da2bc92b05185c48339368872c40e2feb48f04bfee90d8956c74afdd357a968fff04750593a5f9f0782c5526 SHA512 3c8c87f2f4a19e54c4b1962f11a700373f3d3428af6c140b4d2fe8a487092e294036037e4e54fe3c9076c87a38f0723b42154256c9fbac39ac3937f63f425932
+MISC metadata.xml 806 BLAKE2B 12ab88f8c41b905d21b49c60e5adf9dd30a6d19486fc00f79a625bf04427a8c9588df25ad58e52a04ac521b4c6bff5e438470afb857ae773a6cc46b3e377753b SHA512 9a02d6a9c4a9424e009a2b54661768955918eb2654661e8ce966c919b4b4bf8bb6adc2be158f89088d4e140b65c4421f17e8ad5fffabf611c8ab12d074048b0c
diff --git a/dev-libs/libuninum/libuninum-2.7.ebuild b/dev-libs/libuninum/libuninum-2.7.ebuild
new file mode 100644
index 000000000000..2d661dff563d
--- /dev/null
+++ b/dev-libs/libuninum/libuninum-2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A library for converting unicode strings to numbers and vice versa"
+HOMEPAGE="https://billposer.org/Software/libuninum.html"
+SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2.1"
+SLOT="0"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libuninum/metadata.xml b/dev-libs/libuninum/metadata.xml
new file mode 100644
index 000000000000..0db8928175d3
--- /dev/null
+++ b/dev-libs/libuninum/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This is a library for converting unicode strings to numbers and numbers to unicode strings.
+ Standard functions like strtoul, strtod, and sprintf do this for numbers written in the
+ usual western number system using the indo-arabic numerals, but they do not handle other number systems.
+ The main functions take as input a UTF-32 unicode string and compute the corresponding unsigned integer.
+ </longdescription>
+</pkgmetadata>