summaryrefslogtreecommitdiff
path: root/dev-libs/libuninum/libuninum-2.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 17:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 17:37:01 +0100
commit2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (patch)
treef41d653fa88967e28246f7b63dba9f2fd7be2ab7 /dev-libs/libuninum/libuninum-2.7-r2.ebuild
parent6e88bac8dd26372eea042112ad3769b1fac9ae18 (diff)
gentoo auto-resync : 07:05:2023 - 17:37:01
Diffstat (limited to 'dev-libs/libuninum/libuninum-2.7-r2.ebuild')
-rw-r--r--dev-libs/libuninum/libuninum-2.7-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libuninum/libuninum-2.7-r2.ebuild b/dev-libs/libuninum/libuninum-2.7-r2.ebuild
new file mode 100644
index 000000000000..e908d0c3b217
--- /dev/null
+++ b/dev-libs/libuninum/libuninum-2.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A library for converting unicode strings to numbers and vice versa"
+HOMEPAGE="https://billposer.org/Software/libuninum.html"
+SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2.1"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # LTO does not work.
+ # See https://bugs.gentoo.org/855956
+ filter-lto
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}