summaryrefslogtreecommitdiff
path: root/dev-libs/libuev/libuev-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
commitb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (patch)
tree38e677f4a13244ca8ed29a815a0a62f943b430d4 /dev-libs/libuev/libuev-2.1.0.ebuild
parentd37b97a25b8b10f748eead6574b01f893f140b01 (diff)
gentoo resync : 09.12.2017
Diffstat (limited to 'dev-libs/libuev/libuev-2.1.0.ebuild')
-rw-r--r--dev-libs/libuev/libuev-2.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libuev/libuev-2.1.0.ebuild b/dev-libs/libuev/libuev-2.1.0.ebuild
new file mode 100644
index 000000000000..299e8c4aa126
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}