summaryrefslogtreecommitdiff
path: root/dev-libs/libucl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libucl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/Manifest3
-rw-r--r--dev-libs/libucl/libucl-0.7.3.ebuild45
-rw-r--r--dev-libs/libucl/metadata.xml23
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/libucl/Manifest b/dev-libs/libucl/Manifest
new file mode 100644
index 000000000000..4dd9f7440a5c
--- /dev/null
+++ b/dev-libs/libucl/Manifest
@@ -0,0 +1,3 @@
+DIST libucl-0.7.3.tar.gz 1986726 BLAKE2B 8bd772d6bcce5ee6dd0c4611dac596f6168f263aedce7b9f4b1a30527fd9f991767d6db130d7b0e8b33a09357354010644fb8942812be2f06b37648890f491a3 SHA512 29b466254887f7be1168ce31de9f852f3f1868a3afaa5a73859a4cd43b915510850e786ff778613fa48579ee6f0f78e5898c83ce9423f1fb688cce8d969a8eab
+EBUILD libucl-0.7.3.ebuild 973 BLAKE2B f40e0364743acce84dfb3075f07163b496b0fd16b952bca78bdc5d605ff985db2a2dad1c3df551534e043f6630fccbb1211b0af007a794ff5dbe5bab8e0db37a SHA512 ccf1dfb8d53df0009a21c25b18855bfacfa7dd922083b67d6d116e6021963aaa513bd000f78baa6ffa7204918a62ac6689eb7dc16429920ac54158578679a1d9
+MISC metadata.xml 910 BLAKE2B e9c95b0378a94b023aeb151ebc03f53f16794b1117a4b2a17ef205a7e567047dd8681aef9993b90bf88d55ab446e816ca1bca0fe9055a6b0275975df24d15966 SHA512 30aa6e64758a43680a6893516a1902b774d636b671e4191babafa10be4154c2f62da45249109727a7cbf9b9f203e0f97290a3dea70934faf403b7828c6b89a8e
diff --git a/dev-libs/libucl/libucl-0.7.3.ebuild b/dev-libs/libucl/libucl-0.7.3.ebuild
new file mode 100644
index 000000000000..14a8f7579a58
--- /dev/null
+++ b/dev-libs/libucl/libucl-0.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Universal configuration library parser"
+HOMEPAGE="https://github.com/vstakhov/libucl"
+SRC_URI="https://github.com/vstakhov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="lua +regex signatures static-libs urlfetch utils"
+DEPEND="!!dev-libs/ucl
+ lua? ( >=dev-lang/lua-5.1:= )
+ signatures? ( dev-libs/openssl:0 )
+ urlfetch? ( net-misc/curl )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/api.md )
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=""
+ use urlfetch && myeconf="--with-urls"
+ econf \
+ $(use_enable lua) \
+ $(use_enable regex) \
+ $(use_enable signatures) \
+ $(use_enable utils) \
+ ${myeconf}
+}
+
+src_install() {
+ default
+ use lua && DOCS+=( doc/lua_api.md )
+ # no .a's it seems
+ use static-libs || find "${ED}" -name "*.la" -delete
+}
diff --git a/dev-libs/libucl/metadata.xml b/dev-libs/libucl/metadata.xml
new file mode 100644
index 000000000000..6d4d014359bc
--- /dev/null
+++ b/dev-libs/libucl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ UCL is heavily infused by nginx configuration as the example of a
+ convenient configuration system. However, UCL is fully compatible
+ with JSON format and is able to parse json files. It can also emit
+ UCL objects into different formats such as "nginx like", json,
+ yaml and compact json
+ </longdescription>
+ <use>
+ <flag name="regex">Enable regex checking for schema</flag>
+ <flag name="signatures">Enable signatures check</flag>
+ <flag name="urlfetch">Enable URLs fetch</flag>
+
+ <!-- in v0.8.0, also the ucl-tool utility -->
+ <flag name="utils">Install the chargen and objdump utilities</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">vstakhov/libucl</remote-id>
+ </upstream>
+</pkgmetadata>