summaryrefslogtreecommitdiff
path: root/dev-libs/libtompoly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libtompoly
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libtompoly')
-rw-r--r--dev-libs/libtompoly/Manifest3
-rw-r--r--dev-libs/libtompoly/libtompoly-0.04.ebuild32
-rw-r--r--dev-libs/libtompoly/metadata.xml27
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libtompoly/Manifest b/dev-libs/libtompoly/Manifest
new file mode 100644
index 000000000000..8b88e56e4e84
--- /dev/null
+++ b/dev-libs/libtompoly/Manifest
@@ -0,0 +1,3 @@
+DIST ltp-0.04.tar.bz2 171966 BLAKE2B 748fd04d55bd3dcdcd9510de1e34e2b9d96c38fc4f48c14137676f60c6d89751e8a095e07687d368d9a46e49ed056484cf8971e96fc400cde15b254a7374c38c SHA512 64a0b25eb058fc2475e6c645138729796099081ad7e926b58d2e83468d988048607e26716b4b669f0e923ea74d4d9705ff5a0466eb41cbe160488d0173447234
+EBUILD libtompoly-0.04.ebuild 668 BLAKE2B 74503998da247b90dd0a8641d9369ef477ab9f04c1f009c4336afd3981097e319a58fc197677992e34601e1fef92aa05d30065fdc82f92e506180c7584c9fd71 SHA512 722bb9daa56634a2601e8cac7444fcaf58aff3fd633b00ba35436c4ddd1f96a055e80b1c0f1352140fa5a1c4739e407fd3a42e12e3f226d88c21603b8a57abf6
+MISC metadata.xml 1004 BLAKE2B 3a2e6908ade2ae67d90b417083876855f6883dc015ed9a81d3f73dacaf5f9df8e0da0dfc0b732ed1550d7bdd739f3eaa136676d939bd1331bfd4f54acc2698dd SHA512 f11dff1fe992edabb996248d3315e020fe1ef8ac9ee429de47522e292f77e00b4772bc61b985681fa12b295625c5cc9251cc8022de5e444840afbe93fd482cfd
diff --git a/dev-libs/libtompoly/libtompoly-0.04.ebuild b/dev-libs/libtompoly/libtompoly-0.04.ebuild
new file mode 100644
index 000000000000..038467c5d147
--- /dev/null
+++ b/dev-libs/libtompoly/libtompoly-0.04.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="portable ISO C library for polynomial basis arithmetic"
+HOMEPAGE="http://www.libtom.org/"
+SRC_URI="https://github.com/libtom/libtompoly/releases/download/${PV}/ltp-${PV}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/libtommath"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:\<ar\>:$(AR):' \
+ -e "/^LIBPATH/s:/lib:/$(get_libdir):" \
+ makefile || die
+ tc-export AR CC
+}
+
+src_install() {
+ default
+ dodoc changes.txt *.pdf
+ docinto demo ; dodoc demo/*
+}
diff --git a/dev-libs/libtompoly/metadata.xml b/dev-libs/libtompoly/metadata.xml
new file mode 100644
index 000000000000..a4b3cf633bd1
--- /dev/null
+++ b/dev-libs/libtompoly/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <longdescription>
+ LibTomPoly has the following features.
+
+ * Totally public domain and is only dependent on LibTomMath, another public
+ domain library.
+ * Portable source code.
+ * Provides access to polynomials of finite characteristic of varying degrees
+ (it will grow to accomodate)
+ * Includes several algebraic operations.
+ o Usual addition, subtraction, division, multiplication.
+ o Modular versions of the add/sub/mul
+ o Modular exponentiation
+ o Irreducibility testing.
+ o Monic reductions
+ o Comparisons
+ </longdescription>
+ <upstream>
+ <remote-id type="github">libtom/libtompoly</remote-id>
+ </upstream>
+</pkgmetadata>