summaryrefslogtreecommitdiff
path: root/dev-libs/libtommath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
commit6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (patch)
tree122c8899fbcce481ff7c1deb35c872f0236affa9 /dev-libs/libtommath
parente7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (diff)
gentoo auto-resync : 09:09:2023 - 10:33:01
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/Manifest2
-rw-r--r--dev-libs/libtommath/libtommath-1.2.1.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-libs/libtommath/Manifest b/dev-libs/libtommath/Manifest
index 09f52a19ae4a..4c4b0a47afae 100644
--- a/dev-libs/libtommath/Manifest
+++ b/dev-libs/libtommath/Manifest
@@ -1,4 +1,6 @@
AUX libtommath-1.2.0-sparc.patch 1011 BLAKE2B 40eb13efa4e39ed5a3d22c122e808fc7ba33694adbd0c12996aa3b49d599da8795c95ab8d9e1241de4e28f731fe9872f9db1fdd4a872ff0701cf806547c094c0 SHA512 09095a9c4a41f49db14b1dffd766d57f18b2d031920328cc3a8334b452032b9310547807eaf8b4805936082528fff5ce7945e07164a81b556685efbeed6987be
DIST ltm-1.2.0.tar.xz 622120 BLAKE2B 1537dad7da5c14264f03280e9d49fa0b7e6c1c4924c805f202d31c60569b9e3bee40674301d67b0f5b049c1c2dc5ec71b6c566ff5c9b8168d16840b031acc400 SHA512 6f9ccd0691831f07f86ddc81cb6145504b3d5da66dd3e92312c64cce0ea986fa4e08ba65ca8991aaebe56702c2d7c15f309696785b813dffb4c112a4ad04b203
+DIST ltm-1.2.1.tar.xz 635728 BLAKE2B b1464843af4a33f2ba0c824fe2dd080227c6b761b3f8059bbc5229f36d601aecc8bcb20c386718c71a1bc01f69e532647689b43252bd15143f809f7072de449e SHA512 50c9459357aa7f5076af93de6701c617da0dbbf2230a2f4468062704a6cd6e9d3c2fbb27016f68a7e1d6b35d6ddb2088630b24ea6acc20ed8c19594913d36e95
EBUILD libtommath-1.2.0-r2.ebuild 2065 BLAKE2B 62a2ad02530680286bfcb4234a226720d128ce7b25ea2fe41c3e91e485a458111881e284c1d8a8936e97a6ac3c1c52d0c4ddf84c97241af8ab4743a9c117ced1 SHA512 4ea8d5925d0680f89fed1e6b73ba63866034c47607f9e20b4026cc7f73238b8a2f74ed3a62d0df1321204cca686bd36b72e9720a6a14fbcfd0b47f35262ace46
+EBUILD libtommath-1.2.1.ebuild 2080 BLAKE2B 43e5026e49f75513673a40c078466766ff31173cf580f6b6fcd9566f5c8172b662e0e592868594365bc10037da50118f9e89b58d53d6a0e21d0146f89dbc3236 SHA512 53556ba853ea37d6065b82744299da890479e2e4eb255e58ad30d84f23b15ae813d39e3739418f4dea683e75a70c0951cc0e940ba13dc811829ace49dec24ec2
MISC metadata.xml 3152 BLAKE2B ce07678f531abb65f7abde8e75f817b9eb858b9f733e7d04e46f715ace574bfbd19bc8de7ae3725d8e8702f8cb37bb9647dc458f76c0cddbd22a11bbe980dc67 SHA512 bcab3fe5f7a3b59c5b4208c84fab7be5402ad5ec3f4a838ab32975ffd468bec897c420f2094c6920eebaa68a2d1746adbb1bc36b9388c3619c5aa1b3a43bdde8
diff --git a/dev-libs/libtommath/libtommath-1.2.1.ebuild b/dev-libs/libtommath/libtommath-1.2.1.ebuild
new file mode 100644
index 000000000000..a2986670805b
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-1.2.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Optimized and portable routines for integer theoretic applications"
+HOMEPAGE="https://www.libtom.net/"
+SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples static-libs"
+
+BDEPEND="sys-devel/libtool"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-sparc.patch
+)
+
+src_prepare() {
+ default
+
+ # need libtool for cross compilation, bug #376643
+ cat <<-EOF > configure.ac
+ AC_INIT(libtommath, 0)
+ AM_INIT_AUTOMAKE
+ LT_INIT
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+
+ touch NEWS README AUTHORS ChangeLog Makefile.am || die
+
+ eautoreconf
+
+ export LIBTOOL="${S}"/libtool
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+_emake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ IGNORE_SPEED=1 \
+ DESTDIR="${ED}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBPATH="/usr/$(get_libdir)" \
+ INCPATH="/usr/include" \
+ "$@"
+}
+
+src_compile() {
+ # Replace hard-coded libdir=${exec_prefix}/lib.
+ sed -i -e "/libdir=/s:/lib:/$(get_libdir):" libtommath.pc.in || die
+
+ _emake -f makefile.shared
+}
+
+src_test() {
+ # Tests must be built statically
+ # (i.e. without -f makefile.shared)
+ _emake test
+
+ ./test || die
+}
+
+src_install() {
+ _emake -f makefile.shared install
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local path="usr/$(get_libdir)/libtommath.${PV}.dylib"
+ install_name_tool -id "${EPREFIX}/${path}" "${ED}/${path}" || die "Failed to adjust install_name"
+ fi
+
+ # We only link against -lc, so drop the .la file.
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+
+ dodoc changes.txt
+
+ use doc && dodoc doc/*.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+}