summaryrefslogtreecommitdiff
path: root/dev-libs/libtommath/libtommath-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /dev-libs/libtommath/libtommath-1.2.0.ebuild
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'dev-libs/libtommath/libtommath-1.2.0.ebuild')
-rw-r--r--dev-libs/libtommath/libtommath-1.2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/libtommath/libtommath-1.2.0.ebuild b/dev-libs/libtommath/libtommath-1.2.0.ebuild
index 78def9854c3f..c72f2d4668d5 100644
--- a/dev-libs/libtommath/libtommath-1.2.0.ebuild
+++ b/dev-libs/libtommath/libtommath-1.2.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}
LICENSE="Unlicense"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples static-libs"
BDEPEND="sys-devel/libtool"
@@ -65,6 +65,11 @@ src_test() {
src_install() {
_emake -f makefile.shared install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local path="usr/$(get_libdir)/libtommath.${PV}.dylib"
+ install_name_tool -id "${EPREFIX}/${path}" "${ED}/${path}" || die "Failed to adjust install_name"
+ fi
+
# We only link against -lc, so drop the .la file.
find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then