summaryrefslogtreecommitdiff
path: root/dev-libs/libthreadar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-libs/libthreadar
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-libs/libthreadar')
-rw-r--r--dev-libs/libthreadar/Manifest3
-rw-r--r--dev-libs/libthreadar/libthreadar-1.3.0.ebuild37
-rw-r--r--dev-libs/libthreadar/metadata.xml19
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libthreadar/Manifest b/dev-libs/libthreadar/Manifest
new file mode 100644
index 000000000000..48599da8111d
--- /dev/null
+++ b/dev-libs/libthreadar/Manifest
@@ -0,0 +1,3 @@
+DIST libthreadar-1.3.0.tar.gz 440695 BLAKE2B f4f08d27f6be640e44c9a3abb564c2f1b8faf5b10ec26931a77d6de9769b456e577902c8de378d6fc420e930f20a59081e6916e2b4aeb4f083e70a1565570112 SHA512 54257ebefa0473f78510a5add0241f1282e1f135037edeecc76edd0982b6cc279592ae86e1df263327e1e090b7905ab65847ccdc2afdd366c7bac5c3097abd9e
+EBUILD libthreadar-1.3.0.ebuild 933 BLAKE2B 95747b8fd659c15230863063b8a8eff254eca0f09297afcc1b231a6d033ef560f41fde2061f0cd129d0da40bf2830fbe7a89e71e48f1b39cb63757e1257abf64 SHA512 52edd7e75eb9a84a37fce263ac390cf245670ee017b0a69104fc5cf7e8d7e81a816587454556cc074073aaf257c8dcf3c619d8b6dd812108f2312f7fa8cf724f
+MISC metadata.xml 859 BLAKE2B be25bf21b05ec44dc5ba2c6cdfd33e942485a7cdc1a0378040130a9a0b4c1c60fe4876be144cb7185bd349c67e51157c0e740012346fa7bc908a4fa53db87889 SHA512 da0e98e9da10ec81ef56d26ac77f4e358acabb6931b7b09e146240f4a77dc4cc19cde62a200d81c491895cec674f71ec13ce96cb55331178198ad59f4e297ade
diff --git a/dev-libs/libthreadar/libthreadar-1.3.0.ebuild b/dev-libs/libthreadar/libthreadar-1.3.0.ebuild
new file mode 100644
index 000000000000..a3caae2728ef
--- /dev/null
+++ b/dev-libs/libthreadar/libthreadar-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Threading library used by dar archiver"
+HOMEPAGE="https://sourceforge.net/projects/libthreadar/"
+SRC_URI="mirror://sourceforge/libthreadar/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ # Copy this comment from app-backup/dar as it applies here too
+ #
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+
+ local myconf=( --disable-static )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libthreadar/metadata.xml b/dev-libs/libthreadar/metadata.xml
new file mode 100644
index 000000000000..ff22d4ec0241
--- /dev/null
+++ b/dev-libs/libthreadar/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ceamac.paragon@gmail.com</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+Libthreadar is a C++ library providing an abstracted set of C++ *classes* to manipulate threads in a very simple and efficient way from your C++ code.
+It also handles exceptions thrown from a thread and propagated to another one, when the latter is calling the thread::join() method. This lets one manage exceptions as simply as it is in C++ single threaded context.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libthreadar</remote-id>
+ </upstream>
+</pkgmetadata>