summaryrefslogtreecommitdiff
path: root/dev-libs/libtar/libtar-1.2.20-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-28 03:03:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-28 03:03:20 +0100
commit0b1f53c54388382ff701d00d3f5eb981ed040f2a (patch)
treeec5c4665c03dbae83c878cb536837e611a8584a6 /dev-libs/libtar/libtar-1.2.20-r5.ebuild
parent59fb67b05708a525b33b4a84de896b3b1ae34012 (diff)
gentoo auto-resync : 28:07:2022 - 03:03:20
Diffstat (limited to 'dev-libs/libtar/libtar-1.2.20-r5.ebuild')
-rw-r--r--dev-libs/libtar/libtar-1.2.20-r5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libtar/libtar-1.2.20-r5.ebuild b/dev-libs/libtar/libtar-1.2.20-r5.ebuild
new file mode 100644
index 000000000000..c9c26bbb3adb
--- /dev/null
+++ b/dev-libs/libtar/libtar-1.2.20-r5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for manipulating tar archives"
+HOMEPAGE="https://repo.or.cz/w/libtar.git/"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="zlib"
+# There is no test and 'check' target errors out due to mixing of automake &
+# non-automake makefiles.
+# https://bugs.gentoo.org/526436
+RESTRICT="test"
+
+RDEPEND="
+ zlib? ( sys-libs/zlib:= )
+ !zlib? ( app-arch/gzip )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.11-free.patch
+ "${FILESDIR}"/${PN}-1.2.11-impl-dec.patch
+ "${FILESDIR}"/CVE-2013-4420.patch
+ "${FILESDIR}"/${P}-fd-leaks.patch
+ "${FILESDIR}"/${P}-tar_open-memleak.patch
+ "${FILESDIR}"/${P}-bin-memleaks.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e '/INSTALL_PROGRAM/s:-s::' \
+ -i {doc,lib{,tar}}/Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-encap
+ --disable-epkg-install
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc ChangeLog-1.0.x
+ newdoc compat/README README.compat
+ newdoc compat/TODO TODO.compat
+ newdoc listhash/TODO TODO.listhash
+
+ find "${ED}" -name '*.la' -delete || die
+}