summaryrefslogtreecommitdiff
path: root/dev-libs/libstroke
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/libstroke
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/libstroke')
-rw-r--r--dev-libs/libstroke/Manifest2
-rw-r--r--dev-libs/libstroke/libstroke-0.5.1-r1.ebuild28
2 files changed, 19 insertions, 11 deletions
diff --git a/dev-libs/libstroke/Manifest b/dev-libs/libstroke/Manifest
index 0d5376b24781..243fb4dbda8e 100644
--- a/dev-libs/libstroke/Manifest
+++ b/dev-libs/libstroke/Manifest
@@ -2,5 +2,5 @@ AUX libstroke-0.5.1-autotools.patch 734 BLAKE2B 3590484c7a4b96b7faa09eb7e2267365
AUX libstroke-0.5.1-m4_syntax.patch 1100 BLAKE2B c86fed17159d3179bbb538c1c467fa5a34133b6a43d30f2e2862158e0756ea8ca8654ca6f450219c9222cc3612fefddf6170922f410a9c1119f48439acf5daff SHA512 bfe54a1c60c381e01820f46998c1ade66bcc5b816d20d8736334cd097f94fd06921c7ef17ae42e1f4f47090a7a9a6db2121a9960c140ad7dcb4d5ac3acf6fded
AUX libstroke-0.5.1-no_gtk1.patch 1046 BLAKE2B feaaa0206f74bc1206ed464ec3f29c76e2f51c83f78c6821d2184b833e1718638b11757ab3f8cef9464884dc11a3158fccb9f1f9fd166f50ee83f556b447b25d SHA512 96004186c51e617fa53f1bbaef5f58c6572c5acf0a6acf2d9e7be618c443fccff5feb8dd7bf77a9a435b8c5b334e1babb3cbd739e71ec6d7fe7feda1c66607f8
DIST libstroke-0.5.1.tar.gz 174270 BLAKE2B ce642aff20f731ed8dc6aedfcdca0370e4e9789bdf1fd7d4157745ea7375d5e5f9c7a2f00739d886ff348c00ada36c3bef0ce68f18d9b0dd52eabcc086776334 SHA512 03431d4cd39174aadb6cfd00a1c487d34ae9cf4b1db9e9d01d563f2a661f01979f474b87099fd2bfb0e54653416a1b9dea988367674a3cc6134e16b62810a0c7
-EBUILD libstroke-0.5.1-r1.ebuild 702 BLAKE2B cd8ea4dada0945c509a92173ee42f3392631e33fcd8bf1b46f820ee4a3388ac2025477e14cdb9b6b07350a05ae7daa5bcdbba852bc6d01205ae7e1228da663cd SHA512 4d26fcb6bf6ac043cdb2e0c7d58d1681801577d7b751c27165d9da1e0100ca23775dcb17f621c61e9523e4cc09210151c7ba2482815eafbef0ff362e3dc627b1
+EBUILD libstroke-0.5.1-r1.ebuild 740 BLAKE2B 378f3d67aafe339e3b8860a726ce744a51d617adfdf6c841d961b792c31fbf554bb3076b263374da91b359727b9f25d18a4a360c8040bea05d42be8efd283431 SHA512 f18e43d3fc667fe0920daadd33a6909087b9ffa1732ad806f456b8c0f75162854a5f9789450f94106607d30b82d744c903b0a74031a3f767e02791581cecf470
MISC metadata.xml 261 BLAKE2B ed5cc49462c9e948e13f3455fbf209661aa04522f3753db7c674bca0528d7a384beefcbdfc5fcc0542dd08361d7953c06cbd19753bfe4dca2ff649ebc283bbd7 SHA512 318bd063baaa5dd560bcfdb87ab4d60edfb4dddf69884a84ef084a38399cf2ba84e69b432c816cce8e15d3dea253f395f41a1a654017a6eef30478ab8961cb51
diff --git a/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild b/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild
index 1eb5fa30dc6c..cb4bde34cb74 100644
--- a/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild
+++ b/dev-libs/libstroke/libstroke-0.5.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="A Stroke and Gesture recognition Library"
HOMEPAGE="http://www.etla.net/libstroke/"
@@ -12,21 +12,29 @@ SRC_URI="http://www.etla.net/libstroke/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
RDEPEND="x11-libs/libX11"
-DEPEND="x11-base/xorg-proto
- ${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-m4_syntax.patch
+ "${FILESDIR}"/${P}-no_gtk1.patch
+ "${FILESDIR}"/${P}-autotools.patch
+)
src_prepare() {
- eapply "${FILESDIR}"/${P}-m4_syntax.patch
- eapply "${FILESDIR}"/${P}-no_gtk1.patch
- eapply "${FILESDIR}"/${P}-autotools.patch
- eapply_user
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install
- dodoc CREDITS ChangeLog README
+ default
+ find "${ED}" -name '*.la' -delete || die
}