summaryrefslogtreecommitdiff
path: root/dev-libs/libsqlora8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libsqlora8
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libsqlora8')
-rw-r--r--dev-libs/libsqlora8/Manifest3
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild55
-rw-r--r--dev-libs/libsqlora8/metadata.xml12
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/libsqlora8/Manifest b/dev-libs/libsqlora8/Manifest
new file mode 100644
index 000000000000..10a6c2fc4e7d
--- /dev/null
+++ b/dev-libs/libsqlora8/Manifest
@@ -0,0 +1,3 @@
+DIST libsqlora8-2.3.3.tar.gz 1130458 BLAKE2B 7205c808c3e3064bf4aedad62e8cd4685cf6e7eda73e2bb8a13888a81cd0532081de889fd02408633e2df31a522e845b7fec3bee2ececcf39a689b75b75382fc SHA512 5c62387f11cc8b901d99c2981f7e7099d255203aa11a071fc53b22d770db3485f0f23e054b88b3b0f281546a5e92fd5a7bd46b4f0e5f51a8914894c54f222c6e
+EBUILD libsqlora8-2.3.3-r1.ebuild 1264 BLAKE2B c178b2d71faa4c4edb8546f8f0c2f85ac7a0e2a5ef20603fc0144c8412924cc4edc82ad374dc1ca07218a0f983d371db3fd5ba0398412b1f8b4d365cf45ff9d9 SHA512 739b82d31084d43bf053da8dd38958a46479dd6cb764daabc88959022ab5d4887dd069f124c206c654c632d58c34ec328cfd03eecc26a3bc08bdcc2a310392a7
+MISC metadata.xml 417 BLAKE2B 2e4dc2e46bfaf7e9f49ce66f53396ec4320cb8af2aaf80df473e6bd71b056e01ed3e074fc964c7fd0e7c1e212e676c077375f1a91fa6cd7f95ca595de77fe81d SHA512 287a9087ada0f1b1c52601f8f96d326b0e86eadca05d7b05ff0b2a14cd7d62e4a788d48199514a64bd602063068b530b243ee2a696dd205ffd45b44a867d02ee
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..7e8df7fae210
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic versionator
+
+DESCRIPTION="Simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="orathreads static-libs +threads"
+
+RDEPEND="dev-db/oracle-instantclient"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="?? ( orathreads threads )"
+
+src_configure() {
+ local myconf
+
+ local ORACLE_VER="$(best_version dev-db/oracle-instantclient)"
+ ORACLE_VER="${ORACLE_VER#*/*-*-}" #reduce it to ${PV}-${PR}
+ ORACLE_VER="$(get_version_component_range 1-2 ${ORACLE_VER})"
+ append-ldflags -L"/usr/lib/oracle/${ORACLE_VER}/client/lib"
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ # Parallel compilation is not supported
+ emake -j1
+}
+
+src_install () {
+ default
+ prune_libtool_files
+ dodoc ChangeLog NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to proper place
+ rm -r "${D}/usr/share/doc/packages"
+}
diff --git a/dev-libs/libsqlora8/metadata.xml b/dev-libs/libsqlora8/metadata.xml
new file mode 100644
index 000000000000..60a8019dbd9a
--- /dev/null
+++ b/dev-libs/libsqlora8/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>
+ libsqlora8 is simple C-library to access Oracle databases via the OCI
+ interface. Makes simple programming tasks much easier than with plain OCI.
+</longdescription>
+<use>
+ <flag name="orathreads">Use Oracle threads</flag>
+</use>
+</pkgmetadata>