summaryrefslogtreecommitdiff
path: root/dev-libs/libspt/libspt-1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libspt/libspt-1.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libspt/libspt-1.1-r3.ebuild')
-rw-r--r--dev-libs/libspt/libspt-1.1-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libspt/libspt-1.1-r3.ebuild b/dev-libs/libspt/libspt-1.1-r3.ebuild
new file mode 100644
index 000000000000..028608c7a2d0
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-gentoo.patch" )
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms 4755 /usr/libexec/sptagent
+ fi
+}