summaryrefslogtreecommitdiff
path: root/dev-libs/libspt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libspt/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libspt/files')
-rw-r--r--dev-libs/libspt/files/libspt-gentoo.patch29
-rw-r--r--dev-libs/libspt/files/libspt-rpc.patch22
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libspt/files/libspt-gentoo.patch b/dev-libs/libspt/files/libspt-gentoo.patch
new file mode 100644
index 000000000000..f6c709b6b798
--- /dev/null
+++ b/dev-libs/libspt/files/libspt-gentoo.patch
@@ -0,0 +1,29 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -9,7 +9,7 @@
+ libexecdir = @libexecdir@
+ includedir = @includedir@
+ #docdir = $(prefix)/doc
+-mandir = $(prefix)/man
++mandir = @mandir@
+
+ EXEEXT = @EXEEXT@
+
+@@ -29,7 +29,7 @@
+ INCLUDES = -I.
+ DEFS = @DEFS@
+ CC = @CC@
+-COMMONCFLAGS = -Wall -g -Werror -pipe
++COMMONCFLAGS = -Wall -g -pipe
+ CFLAGS = $(COMMONCFLAGS) @CFLAGS@
+ INSTALL = $(LIBTOOL) --mode=install @INSTALL@
+ INSTALL_DATA = $(LIBTOOL) --mode=install @INSTALL@ -m 644
+@@ -48,7 +48,7 @@
+ AGENTOBJS = sptagent.o sptconn.$lo cfuncs.$lo
+ LIBOBJS = libspt.$lo sptconn.$lo cfuncs.$lo error.$lo utilapi.$lo termios.$lo
+ OBJS = test.o $(LIBOBJS)
+-AGENT_MODE = -m 4755 -o root -g wheel
++AGENT_MODE =
+
+ .SUFFIXES: .c .o .cc .lo
+ .c.lo:
diff --git a/dev-libs/libspt/files/libspt-rpc.patch b/dev-libs/libspt/files/libspt-rpc.patch
new file mode 100644
index 000000000000..79b545ace4fa
--- /dev/null
+++ b/dev-libs/libspt/files/libspt-rpc.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,18 @@
+ AC_CHECK_FUNCS([dup2 ftruncate gettimeofday select strcspn strstr]dnl
+ [ strchr memcpy bzero setutent setutxent updwtmp updwtmpx _openpty revoke getsid]dnl
+ [ setsid setpgrp snprintf sigaction cfmakeraw])
++AC_ARG_WITH([libtirpc],
++ [AS_HELP_STRING([--with-libtirpc],[Use libtirpc as RPC implementation (instead of sunrpc)])])
++AS_IF([test "x$with_libtirpc" = xyes],
++ [PKG_CHECK_MODULES([TIRPC],
++ [libtirpc],
++ [CFLAGS="$CFLAGS $TIRPC_CFLAGS"; LIBS="$LIBS $TIRPC_LIBS";],
++ [AC_MSG_ERROR([libtirpc requested, but library not found.])]
++ )],
++ [AC_CHECK_HEADER(rpc/rpc.h,
++ [],
++ [AC_MSG_ERROR([sunrpc requested, but headers are not present.])]
++)])
+-AC_SEARCH_LIBS([xdr_free],[nsl rpclib])
+ AC_SEARCH_LIBS([socket],[socket])
+ AC_SEARCH_LIBS([nanosleep],[posix4])
+