summaryrefslogtreecommitdiff
path: root/dev-libs/libsolv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/libsolv
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libsolv')
-rw-r--r--dev-libs/libsolv/Manifest3
-rw-r--r--dev-libs/libsolv/libsolv-0.6.22.ebuild103
-rw-r--r--dev-libs/libsolv/metadata.xml11
3 files changed, 0 insertions, 117 deletions
diff --git a/dev-libs/libsolv/Manifest b/dev-libs/libsolv/Manifest
deleted file mode 100644
index cc85e5fa6b5c..000000000000
--- a/dev-libs/libsolv/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST libsolv-0.6.22.tar.gz 609489 BLAKE2B 985a80a4f45bedac310c76fe3557064b7c42fdcab5fb753109c12503084938f0fe72903fd2faa01fd8978015269522b8512cf4a08d95bec82be61f766264c887 SHA512 9f5a3fd7c8716a7313c8205edd9906973577f63340667674a5cbba29991bb159d9d1e2444bcd09debadbb23dc2a8e8f2b44a1575685dbb1031b5920c5eb6cbc1
-EBUILD libsolv-0.6.22.ebuild 2604 BLAKE2B c473bca2de0741b0eba4b8a5f32532e29130f5d1e2fbd35eba889a4f60b43daccaa65403d001ec87f0c3d058511268f9863de0961e8c994b6ddbc0afb5ef2ca3 SHA512 4786d6b46566451e759ceaca0fb6fbce3b4f95d8aa22a80057775c3f49b82368e967e104315812763e2a39f9d366eeae188918d8693369399a2d43a601aeec9f
-MISC metadata.xml 318 BLAKE2B 12795487a958e334b54fa2d6ac8c2c2b7f87a9647c4479196ea4f09f911145d1ab570c3ec7d2b051f4c3fa28dd1fec4b0fb8a6d954de6c23adb14c817a75a5b8 SHA512 10ac96e2ff96a625c6c37d040fec0f093bffa2e02c014fa1a06253516bfe78c0ffc26065aa697220830cc9aa25874e54eac2b8c7131558f2c59106d1cfbab75e
diff --git a/dev-libs/libsolv/libsolv-0.6.22.ebuild b/dev-libs/libsolv/libsolv-0.6.22.ebuild
deleted file mode 100644
index 4c701eeb131f..000000000000
--- a/dev-libs/libsolv/libsolv-0.6.22.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-USE_RUBY=( ruby23 )
-RUBY_OPTIONAL=yes
-
-inherit cmake-utils python-r1 ruby-ng perl-module multilib
-
-DESCRIPTION="Library for solving packages and reading repositories"
-HOMEPAGE="https://doc.opensuse.org/projects/libzypp/HEAD/ https://github.com/openSUSE/libsolv"
-SRC_URI="https://github.com/openSUSE/libsolv/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bzip2 lzma perl python rpm ruby tcl"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/expat
- sys-libs/zlib
- bzip2? ( app-arch/bzip2 )
- lzma? ( app-arch/xz-utils )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- rpm? ( app-arch/rpm )
- ruby? ( $(ruby_implementations_depend) )
- tcl? ( dev-lang/tcl:0= )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig:0 )
- python? ( dev-lang/swig:0 )
- ruby? ( dev-lang/swig:0 )
- tcl? ( dev-lang/swig:0 )
- sys-devel/gettext"
-
-# The ruby-ng eclass is stupid and breaks this for no good reason.
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- use perl && perl_set_version
- use ruby && ruby-ng_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # The python bindings are tightly integrated w/cmake.
- sed -i \
- -e 's: libsolv: -lsolv:g' \
- bindings/python/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_VENDORDIRS=1
- -DLIB="$(get_libdir)"
- -DENABLE_PYTHON=0
- $(cmake-utils_use_enable bzip2 BZIP2_COMPRESSION)
- $(cmake-utils_use_enable lzma LZMA_COMPRESSION)
- $(cmake-utils_use_enable perl PERL)
- $(cmake-utils_use_enable rpm RPMDB)
- $(cmake-utils_use_enable rpm RPMMD)
- $(cmake-utils_use_enable ruby RUBY)
- $(cmake-utils_use_enable tcl TCL)
- )
-
- cmake-utils_src_configure
-
- if use python ; then
- # python_foreach_impl will create a unique BUILD_DIR for
- # us to run inside of, so no need to manage it ourselves.
- mycmakeargs+=(
- # Rework the bindings for a minor configure speedup.
- -DENABLE_PYTHON=1
- -DENABLE_{PERL,RUBY,TCL}=0
- )
- # Link against the common library so the bindings don't
- # have to rebuild it.
- LDFLAGS="-L${BUILD_DIR}/src ${LDFLAGS}" \
- python_foreach_impl cmake-utils_src_configure
- fi
-}
-
-pysolv_phase_func() {
- BUILD_DIR="${BUILD_DIR}/bindings/python" \
- cmake-utils_${EBUILD_PHASE_FUNC}
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- use python && python_foreach_impl pysolv_phase_func
-}
-
-src_install() {
- cmake-utils_src_install
-
- use python && python_foreach_impl pysolv_phase_func
- use perl && perl_delete_localpod
-}
diff --git a/dev-libs/libsolv/metadata.xml b/dev-libs/libsolv/metadata.xml
deleted file mode 100644
index 801f1aa5c297..000000000000
--- a/dev-libs/libsolv/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="rpm">Enable support for RPM files</flag>
- </use>
- <upstream>
- <remote-id type="github">openSUSE/libsolv</remote-id>
- </upstream>
-</pkgmetadata>