summaryrefslogtreecommitdiff
path: root/dev-libs/libslz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libslz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libslz')
-rw-r--r--dev-libs/libslz/Manifest3
-rw-r--r--dev-libs/libslz/libslz-1.1.0.ebuild65
-rw-r--r--dev-libs/libslz/metadata.xml20
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-libs/libslz/Manifest b/dev-libs/libslz/Manifest
new file mode 100644
index 000000000000..239e30034b9e
--- /dev/null
+++ b/dev-libs/libslz/Manifest
@@ -0,0 +1,3 @@
+DIST libslz-1.1.0.tar.bz2 229577 BLAKE2B d05b619d0b7b76c2777285ecaf976b75565b50c77e00a1ce042f5a28ab8d527788a75d28d70357a32ea9a98267ae621d5a6e4613e4a7e4f52767e68c77765bb3 SHA512 064e2e8e7091adf863653981e5b677bdb9e64901f61cf3b68f098cf7957a4c32e19cec7d41b8dab61098017119d6ea562350c7fbfa10b5e922f52ac0d6066948
+EBUILD libslz-1.1.0.ebuild 1167 BLAKE2B 1fbad459b2d8205f2f3001e75201860472685366b5e04df4be95176caaf63492e76cc81e501aae3d745e4e7fd1b8f2be6dde48cf4bb186f414b5d8611a599bdf SHA512 8f0252966bc7705e8eefc38638c7fbb8b635517a6cccffd555561c338b4fb99da2c0d885ba3555ec01ce0ddf555bd71d284f51303cd81c80edfff0353402876f
+MISC metadata.xml 1176 BLAKE2B 912f2785a4418e9dda2014a1c7d9d8a47be8d38ceda9b56c45b5ac9ad05f5b0aa0793891d8436823ee1bb3a14f7f1239b15daa4ba1ee6dcf35c42a95e1b910bb SHA512 fd49087a1691173da56b6669a410d0db911b999fce1fba2536832ff13a8b4c7a304410fa5ba0f87b7587bdffab216b620ca5b8549936cbf21375139a402b771d
diff --git a/dev-libs/libslz/libslz-1.1.0.ebuild b/dev-libs/libslz/libslz-1.1.0.ebuild
new file mode 100644
index 000000000000..bf812e97c808
--- /dev/null
+++ b/dev-libs/libslz/libslz-1.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="stateless, zlib-compatible, and very fast compression library"
+HOMEPAGE="http://1wt.eu/projects/libslz"
+SRC_URI="http://git.1wt.eu/web?p=${PN}.git;a=snapshot;h=v${PV};sf=tbz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="amd64 arm ppc x86"
+IUSE="static-libs tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ local -a opts=(
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS}" \
+ USR_LFLAGS="${LDFLAGS}" \
+ shared \
+ $(usex static-libs static '')
+ )
+
+ if multilib_is_native_abi ; then
+ opts+=(
+ $(usex tools tools '')
+ )
+ fi
+
+ emake "${opts[@]}"
+}
+
+multilib_src_install() {
+ local -a opts=(
+ STRIP=":" \
+ DESTDIR="${ED}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install-headers
+ install-shared \
+ $(usex static-libs install-static '')
+ )
+
+ if multilib_is_native_abi ; then
+ einstalldocs
+
+ opts+=(
+ $(usex tools install-tools '')
+ )
+ fi
+
+ emake "${opts[@]}"
+}
diff --git a/dev-libs/libslz/metadata.xml b/dev-libs/libslz/metadata.xml
new file mode 100644
index 000000000000..b70f04c44388
--- /dev/null
+++ b/dev-libs/libslz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <longdescription>
+SLZ is a fast and memory-less stream compressor which produces an output that can be decompressed with zlib or gzip. It does not implement decompression at all, zlib is perfectly fine for this.
+
+The purpose is to use SLZ in situations where a zlib-compatible stream is needed and zlib's resource usage would be too high while the compression ratio is not critical. The typical use case is in HTTP servers and gateways which have to compress many streams in parallel with little CPU resources to assign to this task, and without having to thottle the compression ratio due to the memory usage. In such an environment, the server's memory usage can easily be divided by 10 and the CPU usage by 3
+ </longdescription>
+ <use>
+ <flag name="tools">Install additional tools (zenc, zdec)</flag>
+ </use>
+</pkgmetadata>