summaryrefslogtreecommitdiff
path: root/dev-libs/libslz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libslz
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libslz')
-rw-r--r--dev-libs/libslz/Manifest4
-rw-r--r--dev-libs/libslz/libslz-1.1.0.ebuild65
-rw-r--r--dev-libs/libslz/metadata.xml20
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/libslz/Manifest b/dev-libs/libslz/Manifest
new file mode 100644
index 000000000000..e270e67596b3
--- /dev/null
+++ b/dev-libs/libslz/Manifest
@@ -0,0 +1,4 @@
+DIST libslz-1.1.0.tar.bz2 229577 SHA256 cf6b2c00066890d3c7f40ef00e6620784b9dc4662e9a3b35f2059997037be728 SHA512 064e2e8e7091adf863653981e5b677bdb9e64901f61cf3b68f098cf7957a4c32e19cec7d41b8dab61098017119d6ea562350c7fbfa10b5e922f52ac0d6066948 WHIRLPOOL 00294cac044ac451883463b57734809d079581c62ed2b095e4de7e88b6c0ee25d0c92813c199d6a32147c0702e5b9f9f2d601a1aab750f058386e47c7a790830
+EBUILD libslz-1.1.0.ebuild 1167 SHA256 142411c683d9b9c674298ee440cfb208eb43160e38b6823171cc3317dfd45605 SHA512 8f0252966bc7705e8eefc38638c7fbb8b635517a6cccffd555561c338b4fb99da2c0d885ba3555ec01ce0ddf555bd71d284f51303cd81c80edfff0353402876f WHIRLPOOL 91f4cac9c6c1aa12e5c26998b262fe623c280e78351560c08e0761d202cc53e02a8c1d982ad0268bbffa09177cea56f99ebb4dbc286c179b045c5c9c718a3536
+MISC ChangeLog 689 SHA256 854b21b3d774b5677ee25ceb5598eb6f4527130f800101f8ed71e82e66854eec SHA512 96547b21170f9e21d9d2fd0b470a98b4cf3f1fc483f6339aef9dd96fa52ff5011d8a039aceadd7f3a95283b30173431ac8f0675800db98f9957c81c898821556 WHIRLPOOL e411bdc5b70642eaddb064a6f7da8431166fe7f3e5e84bfc5819701cfd2253524e07cd5cbcc6ef4b86ceb78dd61176f1b2d5f5b19b21bbe77e8451925c8597ec
+MISC metadata.xml 1176 SHA256 26245f9620136f2a0f68c2ab61fb81d0d4d426a202f2bd84f44c48ee86635261 SHA512 fd49087a1691173da56b6669a410d0db911b999fce1fba2536832ff13a8b4c7a304410fa5ba0f87b7587bdffab216b620ca5b8549936cbf21375139a402b771d WHIRLPOOL 92f9d3a88da87b65272a143c9f2c737b7adcd568bf0cb687b03b5c4080f0f92438ee97e1a7260717c756b2800aad396bf5eaf3f74d167c1a40755cfe3f04278d
diff --git a/dev-libs/libslz/libslz-1.1.0.ebuild b/dev-libs/libslz/libslz-1.1.0.ebuild
new file mode 100644
index 000000000000..bf812e97c808
--- /dev/null
+++ b/dev-libs/libslz/libslz-1.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="stateless, zlib-compatible, and very fast compression library"
+HOMEPAGE="http://1wt.eu/projects/libslz"
+SRC_URI="http://git.1wt.eu/web?p=${PN}.git;a=snapshot;h=v${PV};sf=tbz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="amd64 arm ppc x86"
+IUSE="static-libs tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ local -a opts=(
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS}" \
+ USR_LFLAGS="${LDFLAGS}" \
+ shared \
+ $(usex static-libs static '')
+ )
+
+ if multilib_is_native_abi ; then
+ opts+=(
+ $(usex tools tools '')
+ )
+ fi
+
+ emake "${opts[@]}"
+}
+
+multilib_src_install() {
+ local -a opts=(
+ STRIP=":" \
+ DESTDIR="${ED}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install-headers
+ install-shared \
+ $(usex static-libs install-static '')
+ )
+
+ if multilib_is_native_abi ; then
+ einstalldocs
+
+ opts+=(
+ $(usex tools install-tools '')
+ )
+ fi
+
+ emake "${opts[@]}"
+}
diff --git a/dev-libs/libslz/metadata.xml b/dev-libs/libslz/metadata.xml
new file mode 100644
index 000000000000..b70f04c44388
--- /dev/null
+++ b/dev-libs/libslz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <longdescription>
+SLZ is a fast and memory-less stream compressor which produces an output that can be decompressed with zlib or gzip. It does not implement decompression at all, zlib is perfectly fine for this.
+
+The purpose is to use SLZ in situations where a zlib-compatible stream is needed and zlib's resource usage would be too high while the compression ratio is not critical. The typical use case is in HTTP servers and gateways which have to compress many streams in parallel with little CPU resources to assign to this task, and without having to thottle the compression ratio due to the memory usage. In such an environment, the server's memory usage can easily be divided by 10 and the CPU usage by 3
+ </longdescription>
+ <use>
+ <flag name="tools">Install additional tools (zenc, zdec)</flag>
+ </use>
+</pkgmetadata>