summaryrefslogtreecommitdiff
path: root/dev-libs/librevenge/librevenge-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/librevenge/librevenge-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/librevenge/librevenge-9999.ebuild')
-rw-r--r--dev-libs/librevenge/librevenge-9999.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-libs/librevenge/librevenge-9999.ebuild b/dev-libs/librevenge/librevenge-9999.ebuild
deleted file mode 100644
index c40659225a0b..000000000000
--- a/dev-libs/librevenge/librevenge-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="A helper library for REVerse ENGineered formats filters"
-HOMEPAGE="https://sf.net/p/libwpd/librevenge"
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/librevenge"
- inherit git-r3 autotools
-else
- SRC_URI="https://sf.net/projects/libwpd/files/${PN}/${P}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
-fi
-
-LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- sys-libs/zlib[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
-"
-
-src_prepare() {
- default
- [[ ${PV} = *9999 ]] && eautoreconf
-
- # bug 651264
- append-cxxflags -std=c++11
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable test tests)
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${D}" -name '*.la' -delete || die
-}