summaryrefslogtreecommitdiff
path: root/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild b/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
new file mode 100644
index 000000000000..f01b33214f82
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake-utils_src_test
+}