summaryrefslogtreecommitdiff
path: root/dev-libs/libqt6pas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-10 00:08:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-10 00:08:04 +0100
commit0aad4cd3e3fe3db90904ffc51b35e4ff160b53c5 (patch)
treea522875f946841ad0790b8170c9201bb145e09bc /dev-libs/libqt6pas
parent4fe228ee9aa3b9b825d54ace549a5517e153e8bd (diff)
gentoo auto-resync : 10:06:2024 - 00:08:04
Diffstat (limited to 'dev-libs/libqt6pas')
-rw-r--r--dev-libs/libqt6pas/Manifest4
-rw-r--r--dev-libs/libqt6pas/files/libqt6pas-1.0.0-remove-wrapper-of-undefined-method.patch29
-rw-r--r--dev-libs/libqt6pas/libqt6pas-1.0.0.ebuild34
-rw-r--r--dev-libs/libqt6pas/metadata.xml12
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/libqt6pas/Manifest b/dev-libs/libqt6pas/Manifest
new file mode 100644
index 000000000000..b942ce04b5b8
--- /dev/null
+++ b/dev-libs/libqt6pas/Manifest
@@ -0,0 +1,4 @@
+AUX libqt6pas-1.0.0-remove-wrapper-of-undefined-method.patch 1019 BLAKE2B 836d300e9324956d93821a5cae5ed90b1a3dfa06ef3cb8bc375df7b94f7f243d01405a3d6e7d45049b1ce8b44d01bc400bf5264531bb16a2e2b99e12695b1341 SHA512 9f3478fec72f971f5b4479c2567a806d15f8712710034dadaa4d24b7f1a51d5dde69acd93745af2028b83b7f7fdbd8d848571e2a1ea1157cb916be91e2217d5f
+DIST libqt6pas-1.0.0.tar.gz 87513233 BLAKE2B 26e8492194541453230832591445b97827e65b61531078cb4bd1c9f549bcd0aa531fef036f701de885e96f9e56476b0dd1c9465e2388ea43080ba418acbd097e SHA512 85cb3548fab017f2fd97f5fb141d59a0d0ec1412a161f98fea726ad5d6ed32ee2eb6ef6573e058d4df7dfcc067256e842acf994b73c9a50ebfb064657db33881
+EBUILD libqt6pas-1.0.0.ebuild 700 BLAKE2B 524b6e91a884ec778093e24eb0447f6043fa3322956ecf4cee01e848f7602d85aea7ab147c550963df7cb9328ca30a01eeec1b5b221f2b3b4b53ad6780499210 SHA512 ae57cca6ef944cd806371185f0feb5f843ed7fb6f50a0c9bdd7fb0bab7dc79311f5b62b0d95f5adbeb02ac1cf5febc09bac20a60e00d0aec42a1995581f847de
+MISC metadata.xml 419 BLAKE2B e74063206b3d47e3bb7fcbb5ffa9854a7d82786c2a2473393202dbb1faf0fb57fbcbc03a8469c943cf83e35ae67d04d9ace961f55d6c3094cc507282f95813ea SHA512 a92295d28eaa213053c41058caa8cc06fbf29b81ea71d74496729e7481f9782c9417199b12cb9d87e79f2a86b5e18a3bb5d35b3a48ea14a7b4a939938b5851fd
diff --git a/dev-libs/libqt6pas/files/libqt6pas-1.0.0-remove-wrapper-of-undefined-method.patch b/dev-libs/libqt6pas/files/libqt6pas-1.0.0-remove-wrapper-of-undefined-method.patch
new file mode 100644
index 000000000000..a1fad05aa7c7
--- /dev/null
+++ b/dev-libs/libqt6pas/files/libqt6pas-1.0.0-remove-wrapper-of-undefined-method.patch
@@ -0,0 +1,29 @@
+Author: Denis Pronin <dannftk@yandex.ru>
+
+Description: the patch is required to make the libqt6pas project compile since
+QT6 does not have QString::isSimpleText() method any longer
+
+--- a/src/qstring_c.cpp
++++ b/src/qstring_c.cpp
+@@ -1073,11 +1073,6 @@
+ return (bool) ((QString *)handle)->isNull();
+ }
+
+-bool QString_isSimpleText(QStringH handle)
+-{
+- return (bool) ((QString *)handle)->isSimpleText();
+-}
+-
+ bool QString_isRightToLeft(QStringH handle)
+ {
+ return (bool) ((QString *)handle)->isRightToLeft();
+--- a/src/qstring_c.h
++++ b/src/qstring_c.h
+@@ -166,7 +166,6 @@
+ C_EXPORT void QString_push_front(QStringH handle, PWideChar c);
+ C_EXPORT void QString_push_front2(QStringH handle, PWideString s);
+ C_EXPORT bool QString_isNull(QStringH handle);
+-C_EXPORT bool QString_isSimpleText(QStringH handle);
+ C_EXPORT bool QString_isRightToLeft(QStringH handle);
+ C_EXPORT void QString_chopped(QStringH handle, int len, PWideString retval);
+ C_EXPORT void QString_first(QStringH handle, int n, PWideString retval);
diff --git a/dev-libs/libqt6pas/libqt6pas-1.0.0.ebuild b/dev-libs/libqt6pas/libqt6pas-1.0.0.ebuild
new file mode 100644
index 000000000000..08257458f261
--- /dev/null
+++ b/dev-libs/libqt6pas/libqt6pas-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_P="lazarus-3.0-0"
+
+DESCRIPTION="Free Pascal Qt6 bindings library updated by lazarus IDE"
+HOMEPAGE="https://gitlab.com/freepascal.org/lazarus/lazarus"
+SRC_URI="https://downloads.sourceforge.net/lazarus/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lazarus/lcl/interfaces/qt6/cbindings"
+
+LICENSE="LGPL-3"
+SLOT="0/2.2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtbase:6
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-remove-wrapper-of-undefined-method.patch"
+)
+
+src_configure() {
+ eqmake6 Qt6Pas.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/dev-libs/libqt6pas/metadata.xml b/dev-libs/libqt6pas/metadata.xml
new file mode 100644
index 000000000000..6fb99b74aaf9
--- /dev/null
+++ b/dev-libs/libqt6pas/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amynka@gentoo.org</email>
+ <name>Amy Liffey</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">freepascal.org/lazarus</remote-id>
+ <remote-id type="sourceforge">lazarus</remote-id>
+ </upstream>
+</pkgmetadata>