summaryrefslogtreecommitdiff
path: root/dev-libs/libpqxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 05:16:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 05:16:35 +0100
commita9a8100d7a659b808e3a112a113b65e16f0070c3 (patch)
tree569b6999f7cf4a797a2cf30299badf776d3b398b /dev-libs/libpqxx
parent2ebceb686e2370a0a9172a7be4a3c29555a08b80 (diff)
gentoo auto-resync : 30:04:2023 - 05:16:35
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/Manifest2
-rw-r--r--dev-libs/libpqxx/libpqxx-7.7.5.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/Manifest b/dev-libs/libpqxx/Manifest
index 753fb3a23229..ab8c432c79da 100644
--- a/dev-libs/libpqxx/Manifest
+++ b/dev-libs/libpqxx/Manifest
@@ -1,5 +1,7 @@
DIST libpqxx-7.4.1.tar.gz 702581 BLAKE2B 9190b62eaf4cee188e32611acfc938a4111e5ea510df50e424ebd3b6c73fe91dfc8fecd5f889dc2af95756f04c87a410a136cd4b4d6d1f276ce2e5fc26906df3 SHA512 a30a9f5ca87944922c9a3bd92d53392855ac3b2760cb7c21411caf364e443c25d1b2d4b4022e60ff7b30bc530fc3223ab3983325217d47fd7d71375c165c8c21
DIST libpqxx-7.7.4.tar.gz 745900 BLAKE2B 2306ca1481cb36d32a5911452944404d90760890dfa1f78eca1f9bd0aa8b194484f4a82f15eca2bb37ea9dc80baa81dba5dee45255c04ed7df7aaa01920747ad SHA512 dd8fc9887eec81356d3c6cbcd11543e76bda8caebc770851bb6cf6e3eb5284ef33fc45f6de54c4cc902e07b06a8064f141841ad041addcc0e669d19486b7b4e1
+DIST libpqxx-7.7.5.tar.gz 745921 BLAKE2B 0ca9b36aecc96a436023621a1fcfcac2732443fe9d85507a64b511914a606a05f1a1d7e569dbf893d47412fb4040d02c0af2c8de280335d1f7a43240464df59d SHA512 78f1f17f5083347cfce607349d4f62be2878c41150c4afd1f26844dc796d0fe190b387b295e1b6bf9d81a26a0ebe1d82597fa651227c3a1cfe3acbd02ea7246c
EBUILD libpqxx-7.4.1.ebuild 2034 BLAKE2B e75b11b7430d4a5511ebf3d13d9aca155af89d453dd4ba4375d605611addcf736a1788d33b44b69058b6655d57da4587d9d12ed05a66b37399b59c14cbc509bd SHA512 10adb26f5f26afabd0aad13f2c17a31d4345bc608ad39b3ceded97d0895d680f5708b097660180ef716340e9ec7fb65f5526791a09db0e7bacae1c27f8e7182f
EBUILD libpqxx-7.7.4.ebuild 2084 BLAKE2B be397ebfbfd0ecdefa5652bc633a61fc69f150536b8a488dbee2a39bb0b02d2764821d59bd73a7ff907864f37dd569e72378198dbe123da92a11a63b64e0fffb SHA512 6eb04deda962611922d1107732f2dcfa1533b3b5f629e9aa79ca0eafddd26d71457af550bd9d4ac701d68ad740df9d2667da5e18ab950793ec4589ef167251b3
+EBUILD libpqxx-7.7.5.ebuild 2091 BLAKE2B 42d016242f093acabb452a2126d8613ac179e75778860deb412e58bf42689861053d178e8dce75f6aea6a3855c9444208f9e4f6f1c1c23940c3b230cb1045b37 SHA512 0e1c684dbf400e7e35b8063d791835df8760f26c1a7d7cbf14270b1e82a2b7e3077cbbe31d52ded688a8e24fb72c64878e20e2c3b6a642195c157fdcebb3d0c9
MISC metadata.xml 612 BLAKE2B 87ee08bf17de287e29818b4345fcf208fa9f024775be18e9c696265e08cad5ca3da7e9d75c5f1b4320a229f1fc9210f798ffdc97e21093aa0a9ac893ebae8dd7 SHA512 082e69f1ddd4d88c039a4aa7c386f69d3a643d675e442db6c12114167f0fe641649bb7f349cd79251b10fedd60404b31cf923ff12f5a72d6128808e18682ddf4
diff --git a/dev-libs/libpqxx/libpqxx-7.7.5.ebuild b/dev-libs/libpqxx/libpqxx-7.7.5.ebuild
new file mode 100644
index 000000000000..1136bd19efe9
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-7.7.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+HOMEPAGE="https://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+# SONAME version is equal to major.minor
+SLOT="0/$(ver_cut 1-2)"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen[dot]
+ app-text/xmlto
+ )
+"
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${BROOT}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${BROOT}/etc/libpqxx_test_env ]] ; then
+ source "${BROOT}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ cd "${S}/test" || die
+ emake check
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}