summaryrefslogtreecommitdiff
path: root/dev-libs/libpqxx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libpqxx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/Manifest3
-rw-r--r--dev-libs/libpqxx/libpqxx-6.0.0.ebuild86
-rw-r--r--dev-libs/libpqxx/metadata.xml15
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/Manifest b/dev-libs/libpqxx/Manifest
new file mode 100644
index 000000000000..cf75c7560451
--- /dev/null
+++ b/dev-libs/libpqxx/Manifest
@@ -0,0 +1,3 @@
+DIST libpqxx-6.0.0.tar.gz 676528 BLAKE2B a40095ba9851acde1296d93af7e4c4414f334a734b5062874b63a146836105fdde24672707caf623f2073dc1caf87b1053f25c80b10c3fa779fc91a52f9ec7ae SHA512 f237cc03c01a8262eee44a9428206c1cc11b6034dddf540afef145f58eee5c32b880d84832563480d73d834c24311170e2ef6789e100793afbe0b6e393bd4169
+EBUILD libpqxx-6.0.0.ebuild 2180 BLAKE2B 7d701220cf445748f4e67104c36bc3d9c8ffbee6633ed578c676416586b440477da4bf48fc31c2291dff2f52e33f5760891177a01098254bdff5f2523da1708b SHA512 9b85c12d7be7acca245f52557cc11063b3064ce8ee09292c31a35402648de7f555134731d675835353ab1ca0639553b4c84adaddb2e92389c7e715eeb51282f0
+MISC metadata.xml 597 BLAKE2B 2371e4c701506d5e8b4eb0938325a6cd909ad874badbc000a7ea831d2e7ff55cf1b6f4fbb3ae09f9392850319f9cbbbde083492a20cf1209e94139f7b1ceb927 SHA512 c732dc922e3ac9e63a373dbe8b53ef8fb93d87c7cd91a1db1b94e89fe33f3109b818cf0730df36b00f2abf1dc554e1bf261f39db807cf61775b8177db231d37f
diff --git a/dev-libs/libpqxx/libpqxx-6.0.0.ebuild b/dev-libs/libpqxx/libpqxx-6.0.0.ebuild
new file mode 100644
index 000000000000..6f10efcd3469
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-6.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ )
+"
+
+DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
+
+src_prepare() {
+ default
+
+ sed -e 's/python/python2/' \
+ -i tools/{splitconfig,template2mak.py} \
+ || die "Couldn't fix Python shebangs"
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${EROOT%/}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
+ source "${EROOT%/}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ cd "${S}/test" || die
+ emake check
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}
diff --git a/dev-libs/libpqxx/metadata.xml b/dev-libs/libpqxx/metadata.xml
new file mode 100644
index 000000000000..7a7404b989eb
--- /dev/null
+++ b/dev-libs/libpqxx/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>pgsql-bugs@gentoo.org</email>
+ <name>PostgreSQL and Related Package Development</name>
+ </maintainer>
+ <longdescription>
+ libpqxx is the official C++ client API for PostgreSQL. If you are
+ writing software in C++ that needs to access databases managed by
+ Postgres — on just about any platform — then libpqxx is the
+ library you use. Supersedes the now defunct libpq++ (AKA, libpqpp)
+ API.
+ </longdescription>
+</pkgmetadata>