summaryrefslogtreecommitdiff
path: root/dev-libs/libofx/libofx-0.9.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-libs/libofx/libofx-0.9.15.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-libs/libofx/libofx-0.9.15.ebuild')
-rw-r--r--dev-libs/libofx/libofx-0.9.15.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libofx/libofx-0.9.15.ebuild b/dev-libs/libofx/libofx-0.9.15.ebuild
new file mode 100644
index 000000000000..5daccd32df70
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Library to support the Open Financial eXchange XML format"
+HOMEPAGE="https://github.com/libofx/libofx"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+BDEPEND="
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( app-crypt/gnupg )
+"
+RDEPEND="
+ >=dev-cpp/libxmlpp-2.40.1:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ >app-text/opensp-1.5
+"
+
+PATCHES=( "${FILESDIR}/${P}-docdir-nothanks.patch" )
+
+# workaround needed for ofxconnect to compile
+MAKEOPTS="-j1"
+
+src_prepare() {
+ default
+ eautoreconf
+ append-cxxflags -std=c++14 # bug #566456
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+ if ! use static-libs; then
+ find "${D}" -name '*.a' -type f -delete || die
+ fi
+}