summaryrefslogtreecommitdiff
path: root/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild')
-rw-r--r--dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild b/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
new file mode 100644
index 000000000000..eada1d63f64d
--- /dev/null
+++ b/dev-libs/libmongo-client/libmongo-client-0.1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="The alternative C driver for MongoDB"
+HOMEPAGE="https://github.com/algernon/libmongo-client"
+SRC_URI="https://github.com/algernon/${PN}/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm hppa x86"
+IUSE="doc"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+ use doc && emake DESTDIR="${D}" doxygen
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ use doc && dohtml -r docs/html/*
+}