summaryrefslogtreecommitdiff
path: root/dev-libs/libmateweather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/libmateweather
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/libmateweather')
-rw-r--r--dev-libs/libmateweather/Manifest2
-rw-r--r--dev-libs/libmateweather/libmateweather-1.22.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/Manifest b/dev-libs/libmateweather/Manifest
index cb653c3ab2ed..343e49474ab9 100644
--- a/dev-libs/libmateweather/Manifest
+++ b/dev-libs/libmateweather/Manifest
@@ -1,3 +1,5 @@
DIST libmateweather-1.18.2.tar.xz 3455940 BLAKE2B 15cb57c0202c1117f203bd9550c86d255404984e9163a7f79b8f81a0c436ff6bf9e1945536a15078ad479c9379798966337b6b8851ec84384ccc08c352d06260 SHA512 9b0f9b11f0c9b472a13adc1cfd26076dffd278e0154efa4248f8cc4a999250c88c761985b9a18978a7581e5459232fe2314181ae26a1c7c4fd4c80b536827504
+DIST libmateweather-1.22.0.tar.xz 3386920 BLAKE2B 312bd8cd12a1d51216b9509b2badaccb23779f1c7c314ecf02c9789837fa619d6029e97bf06f9fd320ba590936888d51fe178cffbb7dca87eb167ed4fbf3eabb SHA512 43371fc615dda2b9042633a63ac4c1fb0b1ea43b20c783e443b0f57e10ad8fddedbd593f03bd6c942729f0a9c80484266fe1ef900d128fa4b02f80d6a80ae9bd
EBUILD libmateweather-1.18.2.ebuild 841 BLAKE2B 89c03dce2df151e8543f7bf98e0adf752121193cfc0880a85934c939bddc09bfa65a280caff3cd1c82fd0bcc8abd7104bf44eef4eb408fa960b34159945fcaac SHA512 62bd8582102a4e79ddf286bd86325107cde4c7219b41e58ed2aa0669b03223f8f5a208c445c9c7e24e6111497bb8f33cce8a117e7309e4a1a16960eb4d5d0331
+EBUILD libmateweather-1.22.0.ebuild 866 BLAKE2B 13d62d2a2f55053d69b5cbd7aab37a5ce706edaba5adbf9b2217a50b2b87a633e520a64f53c7210b95862db4690fb07f188aa1a58886f2e9496f25a161d6b217 SHA512 7b7aa77e59725bbe784fee862b64dbc9e0f4af5d40f287580304b81a62064d5dc34b57cf0771e86b06ca3eb1b4b1771bf452da86ef26b9d03be6ca66b8c091bd
MISC metadata.xml 343 BLAKE2B 2c44370234b1e71de86ca5e1fc09ab633185cd1401071d3487b8d4c582115f92e30ace26aca5d3dfb89b8c4aefade6ae4bf6b93776fa123206e638b83e0df9d7 SHA512 1bc3a926850df9eabb80136639bc47809b0c49bcefc37c990cb7941a3629c7a0b2b4e6b538c5af7dcb2187239792b500185349a1ba6befe5b85f191b73467a2a
diff --git a/dev-libs/libmateweather/libmateweather-1.22.0.ebuild b/dev-libs/libmateweather/libmateweather-1.22.0.ebuild
new file mode 100644
index 000000000000..b18cfadd7ef9
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.22.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.34:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.0:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}