summaryrefslogtreecommitdiff
path: root/dev-libs/libmacaroons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libmacaroons
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libmacaroons')
-rw-r--r--dev-libs/libmacaroons/Manifest5
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild40
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild40
-rw-r--r--dev-libs/libmacaroons/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/libmacaroons/Manifest b/dev-libs/libmacaroons/Manifest
new file mode 100644
index 000000000000..ca5196980d73
--- /dev/null
+++ b/dev-libs/libmacaroons/Manifest
@@ -0,0 +1,5 @@
+DIST libmacaroons-0.2.0.tar.gz 423629 BLAKE2B 8f3b58cbc31ad63e5e474dc76810cd921f6ee57d9836cceafcc2881518c87d185fddb48de13adb7f85fff5b831ce7abd53969ba8b0c96722909f855bb12d303f SHA512 4bc5f83b57c6a8080e646141a3c8b90c0025a894449dea4cb0ab15d1423a067b9833e70014468437d9edfe875e12ea90cae6f715893ded1eefa34f2f6506ecbe
+DIST libmacaroons-0.3.0.tar.gz 422086 BLAKE2B 16f398c93230ce745b302d212b58df1e154c8539f76437bbb49d07015c7445484fb5c187294c9a7a1fe6f33ab626a8d9a2fb4784b6bd9b652479072aaf2f0016 SHA512 57a5ffa1a8397228e29ab3f3f7d1440cd70b163b1b28904a046d7b3b1f70dbb0693ea983409f57cc63a02097a1af57209c70ecf8e3be5b8635a7ab6e498b1bcb
+EBUILD libmacaroons-0.2.0-r1.ebuild 778 BLAKE2B 5176f74627e73c6a59ea0588a81bfa6e27ae6b141bd26a0200106a2f83392d6cb173a84e45b966b4ffa844afc8af8028191c35bba657f398855e2a5dd0b2229e SHA512 22a7f6a0c5630d919ae312ab803f9b5c2958f832855e245643cb46ba4d44742b5327c3b92cd1a4700ab94f87a93060332587b8a6f86a245f417e4abdffb480be
+EBUILD libmacaroons-0.3.0.ebuild 778 BLAKE2B 5176f74627e73c6a59ea0588a81bfa6e27ae6b141bd26a0200106a2f83392d6cb173a84e45b966b4ffa844afc8af8028191c35bba657f398855e2a5dd0b2229e SHA512 22a7f6a0c5630d919ae312ab803f9b5c2958f832855e245643cb46ba4d44742b5327c3b92cd1a4700ab94f87a93060332587b8a6f86a245f417e4abdffb480be
+MISC metadata.xml 247 BLAKE2B 5a20af3c9732ef7dba68131a08988652f5c93a6d186a82c4deb1bb9c06dc3ae73152a0d241cc346637f7b11caf4676da43301ba596c67b66669535e71db0b03e SHA512 29cf52c16b0cce69899d9c2da8acd9144b7d760442aa323b854dceadb42459e009545193b1df7911ac2241b59f4819b4a6bb1d206d6f57953f770031433bb6b7
diff --git a/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..448465a2c6ea
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Hyperdex macaroons support library"
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libsodium
+ dev-libs/json-c:=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python python-bindings)
+}
+
+src_test() {
+ emake -j1 check || die
+}
diff --git a/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
new file mode 100644
index 000000000000..448465a2c6ea
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Hyperdex macaroons support library"
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libsodium
+ dev-libs/json-c:=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python python-bindings)
+}
+
+src_test() {
+ emake -j1 check || die
+}
diff --git a/dev-libs/libmacaroons/metadata.xml b/dev-libs/libmacaroons/metadata.xml
new file mode 100644
index 000000000000..40aa45df2b01
--- /dev/null
+++ b/dev-libs/libmacaroons/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>