summaryrefslogtreecommitdiff
path: root/dev-libs/liblouis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-libs/liblouis
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-libs/liblouis')
-rw-r--r--dev-libs/liblouis/Manifest2
-rw-r--r--dev-libs/liblouis/liblouis-3.13.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/liblouis/Manifest b/dev-libs/liblouis/Manifest
index 5832b21a31d5..969ac3e3fc8a 100644
--- a/dev-libs/liblouis/Manifest
+++ b/dev-libs/liblouis/Manifest
@@ -1,3 +1,5 @@
DIST liblouis-3.10.0.tar.gz 13335626 BLAKE2B a4c7f81f15c202c0e1030119f805e218dd51852af57065c441241f4e182828036372750231726802adbb835a7af05ccbf029316da376f3f89dd62ae9d833f838 SHA512 e05d42ba352b1336b10ecd3d320c2bed33250cd636767ecd77837530577c537de4f4e806ddaf1ed7e8b9ec766c84adf6ab045595235c1020f2bb31ba791f3833
+DIST liblouis-3.13.0.tar.gz 14683684 BLAKE2B 9596fac30ee8512498826ea11c3fe4d9dfba6706166938852242533f1fadde9ca8e363ea1364ebb4266b366ee49863d84ad757f8634d90e48dd8c562c31e9e8d SHA512 68f0205dc55a106c5707f959c1c0d3c121dfe62f263a664e6bec0780bee65cce2fb5d7033ae1c8312d1d79f7ccaf650af71906e8651b60f11219758e41051b61
EBUILD liblouis-3.10.0.ebuild 1514 BLAKE2B 5fdb331c3cd0cffc293d4eb49d12686aa913757f22533a29d8f8ad9a498556d3128d2ef44275a40ead84b5ca169b14882131d39f67651b197a9d1441e90be4f9 SHA512 3e8be1ca7bdf9cdaf0ebc30daa19b06354a71ef18979cc8151d9b1dfd9bb54980b5afc69c429d983c059b3e4694916c1ec2ad6b2e92520fa350d58854a7a3b4a
+EBUILD liblouis-3.13.0.ebuild 1682 BLAKE2B 979eb181e93cd5e089af020249deeca069fa1e5c032cfbc0932c0cbbc25ccb9c98da1577f473d81244f5e99aa83ae9f0ba616337672ca326bab202995ae3838d SHA512 c026396e1e072a9e71cb39246b6a9259e352e71fad33c8995328922de22bb89c9298c3a1677c5882c89abfcc33ea4fc61114197fc78c8db76988bdd7d67e251d
MISC metadata.xml 351 BLAKE2B 0fa7c957682fe363ddd29442ae153152469cc64ebf9005361c4b82f180c380485adf0b04467b147a441c6656ddcc9e44967fd692ed9f835d70653dbae9b9be1a SHA512 377a2d9ea4bc6007a60fcaf0284bd47af78b6fe2c901916f9cd7d6ab0f7a5225baf7314b47b0c3b00cd162278f910206bd99469bdef0165cd6e19c1eff73714d
diff --git a/dev-libs/liblouis/liblouis-3.13.0.ebuild b/dev-libs/liblouis/liblouis-3.13.0.ebuild
new file mode 100644
index 000000000000..c9ac3b45c4a7
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-3.13.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://github.com/liblouis/liblouis/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/setuptools-42.0.2[${PYTHON_USEDEP}]
+ )
+ test? ( dev-libs/libyaml )
+"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ econf --enable-ucs4
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ # These need to be after distutils src_install, or it'll try to install them from under python/ as well
+ DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
+ HTML_DOCS=( doc/liblouis.html )
+ default
+}