summaryrefslogtreecommitdiff
path: root/dev-libs/liblogging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/liblogging
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/liblogging')
-rw-r--r--dev-libs/liblogging/Manifest5
-rw-r--r--dev-libs/liblogging/liblogging-1.0.5.ebuild35
-rw-r--r--dev-libs/liblogging/liblogging-1.0.6.ebuild46
-rw-r--r--dev-libs/liblogging/metadata.xml24
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-libs/liblogging/Manifest b/dev-libs/liblogging/Manifest
new file mode 100644
index 000000000000..01fbee7b3ebf
--- /dev/null
+++ b/dev-libs/liblogging/Manifest
@@ -0,0 +1,5 @@
+DIST liblogging-1.0.5.tar.gz 571051 BLAKE2B 46959fa20d4cf00dff1eaa099ad69c199b18036cc05a65945c5abefa2462279577de88e5374fe8486770f9437888562f09f63b3e05015f57ea645a54f7c6c56e SHA512 fd0c89b670bdf4d257d6a31b18b44940ba2edae84633ead6577f164e1ded93709445c35027a28f6e7fda4c984964c3446978eaf0abf843e31ecc11b979e2adde
+DIST liblogging-1.0.6.tar.gz 593393 BLAKE2B c2ca93225b7594c2c064f14e83f475cf2f3dbf608e77e103759371e81e0052e49624740c35f29b7bf9cd1872f4f85f286a2c903f503bebb170a5337d0dfe0677 SHA512 09c90a93b2d32afa44be5a800705a64690810a56d21bed1455cb70680b01fecd4efef3881a43f98ebcafa996b6046ed8e5af935eacc12014f330a7fd23674964
+EBUILD liblogging-1.0.5.ebuild 735 BLAKE2B 9c7d51507c6de7ebb7b040b55aa60e7ebb21108b6092813c7119bd91ffcfd74f2c434f53a9d392069165c985f0d942149af8bec11c57bed6aefac1a9af0106d6 SHA512 9cdb8e7a153da3c646ca9fcaa24c928dc5f8eeca715bdfec6168a924d823ce8871140eb6b049aad3869ab4373d02e17785c580ed7a12ab28d8d102790b045b04
+EBUILD liblogging-1.0.6.ebuild 813 BLAKE2B 9f0f75b4d4cc1f28daf26e33982eb6f338e8569905f8a0f8f9f81fa676cb7bb0aee18a120c988ca909aefa5438b5ded2a2590de3dc7bf1c32c55c2155a573f4e SHA512 adc5da8bdb207461fcd51a15953df1ff00d07ea9bc4ea6467ddbd1889a22041b818e183a3ee795cd008cdf53eb0cd79f408c5f6031ad86c6c58d4f38d580f72a
+MISC metadata.xml 731 BLAKE2B b90fd6b63701e1a86f4ebb4e2c0d2139aa029a2bc7886e53491fae69feb589bc041b6fff7d0cab3f9b818cf0e979e2f51314e8e2d08ea2e64b96f580df1bef34 SHA512 3d8645d66e6e193d29b720ad618ca530ed793d229fe38afeae43a2bc741e3794d993ab97ac04b1e5cc2979472c81265bf43ed27786c1b3663320747c09fd0464
diff --git a/dev-libs/liblogging/liblogging-1.0.5.ebuild b/dev-libs/liblogging/liblogging-1.0.5.ebuild
new file mode 100644
index 000000000000..b9afb6796d1b
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="amd64 arm ~arm64 hppa x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/liblogging/liblogging-1.0.6.ebuild b/dev-libs/liblogging/liblogging-1.0.6.ebuild
new file mode 100644
index 000000000000..920b54472c5a
--- /dev/null
+++ b/dev-libs/liblogging/liblogging-1.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
+HOMEPAGE="http://www.liblogging.org"
+SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0"
+KEYWORDS="amd64 arm ~arm64 hppa x86"
+IUSE="rfc3195 static-libs +stdlog systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable rfc3195)
+ $(use_enable stdlog)
+ $(use_enable systemd journal)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}
diff --git a/dev-libs/liblogging/metadata.xml b/dev-libs/liblogging/metadata.xml
new file mode 100644
index 000000000000..50284e1c1566
--- /dev/null
+++ b/dev-libs/liblogging/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ultrabug@gentoo.org</email>
+ <name>Ultrabug</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <use>
+ <flag name="rfc3195">
+ Enables RFC 3195 protocol (aka syslog-reliable) support.
+ If you don't know what this is, you don't need it!
+ </flag>
+ <flag name="stdlog">
+ Enables liblogging's core component (think of it as a the next version of the syslog(3) API).
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rsyslog/liblogging</remote-id>
+ </upstream>
+</pkgmetadata>