summaryrefslogtreecommitdiff
path: root/dev-libs/libjodycode/libjodycode-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 16:27:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 16:27:39 +0100
commitb98a1d0a0651765f29a8aeab25f904e730dfbf88 (patch)
tree642dd70fc8cbbb3fc9924bbe12d1f571053ffc47 /dev-libs/libjodycode/libjodycode-3.1.ebuild
parent870be9524d5a85e6be7803b3f4eae71fd93cb530 (diff)
gentoo auto-resync : 10:07:2023 - 16:27:39
Diffstat (limited to 'dev-libs/libjodycode/libjodycode-3.1.ebuild')
-rw-r--r--dev-libs/libjodycode/libjodycode-3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libjodycode/libjodycode-3.1.ebuild b/dev-libs/libjodycode/libjodycode-3.1.ebuild
new file mode 100644
index 000000000000..ed722e353ab5
--- /dev/null
+++ b/dev-libs/libjodycode/libjodycode-3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shared code used by several utilities written by Jody Bruchon"
+HOMEPAGE="https://github.com/jbruchon/libjodycode"
+SRC_URI="https://github.com/jbruchon/libjodycode/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# missing test script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.1-static-lib.patch
+)
+
+src_compile() {
+ emake sharedlib
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIB_DIR="/usr/$(get_libdir)" \
+ PREFIX="${EPREFIX}"/usr \
+ install
+ einstalldocs
+}