summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 06:56:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 06:56:55 +0000
commit9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (patch)
tree464689c17706867ab99f0e14017c82d3b3c98a11 /dev-libs/libixion
parented0a1596c807e379a19960170c94735aff22fa84 (diff)
gentoo auto-resync : 27:01:2024 - 06:56:55
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest4
-rw-r--r--dev-libs/libixion/libixion-0.19.0.ebuild57
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild12
3 files changed, 66 insertions, 7 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 94a79e433ca4..39be30bb4b24 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,4 +1,6 @@
DIST libixion-0.17.0.tar.xz 499836 BLAKE2B c8c31b07ad14dd49be259686af3e39e6f5d4aeeb8680030ea7bd2697c8baa72123f2659b3087f224f956612dc444c97e6a6d331fd3deff780981bab4d5b6ad25 SHA512 0acdb2eae5250236a94b1a3344ca990058ea8db7b1e741545bcb7160f9e28d21a3c2ec336621fd590df10188a4d5feadfbb3a63f57e9bfd2cc1bffc04009ffad
+DIST libixion-0.19.0.tar.xz 536540 BLAKE2B 2bd8db83f926d553b1b6c78eb3e735e9911dbdd3cb95105fca04fd560099f38c5e4834d5887b1b0e6d44343e0da9b0fa0264f00c931a6b04b7e4c70996f819b2 SHA512 f06edbcf5ae7459a46e01273952ce6fbc4e8f2b7782c7e07645dc30e102f20f542e449acafc26484765207b10656e0b350f4108cbf1e03947ee7267254cf6f97
EBUILD libixion-0.17.0-r1.ebuild 1171 BLAKE2B 618f5a1c5988f0f9e65016d33abf1e8fdb7efa7f61bb37b7a6306e1afadb6cad3359f64553736aa9954f8155e8cddb4b124c33788ca8e7bb0df5f136ee2d57f4 SHA512 536aaed0cc3f7490d057dc800e0bd3f14f7e6280b12c5fc2f1a623c66f7284b73c86359e3cfd1d263bb5a81a80b5060f4218bd8a918b67f8d77eeedee631e129
-EBUILD libixion-9999.ebuild 1166 BLAKE2B 1d2ab3ad274add875cb87b50ca8d9c8d07dc1ba12fcbad5337a7bbe00fc919ac3f0bf441d9f653d528f314f5b4d1909e5a81f6c553e55b0cb60aecc2c427f736 SHA512 f1b6fdf21ee1641fbe04bb8278e834b1c9d237341cf91dc8f737d18853f07da0dbeef179e400bf1983538f57ae126f647bdc4b05a49e0137fb2695414d1d3a6a
+EBUILD libixion-0.19.0.ebuild 1174 BLAKE2B d88b0a84635a781d9a64d6d6bef8f07dc4881e6a4e349005bfdd4648f2efa58d76ad5d6ee04cbd03dcc51c2f369089cceab3e46a6a44c71db1ac8d1766b4c32e SHA512 efe36515ce739b2252ffd3117c8c7b91644f4abddbe13f7aca9f3f3491ea6c26f1f3046a5cb037ed1e4bdff16cbb5a2d8b118e2a48a0d5bab05a6cfd0cf23039
+EBUILD libixion-9999.ebuild 1174 BLAKE2B 8999d4e26d35edb2ec080f3dd2fea5eee6f9f33f0be0a9c34f59c3c3daf40c538f040c44c8fd2b59dbfa4c437bb7a53ce37f74f0f81d221b2171fe57275885ce SHA512 9c2890e4cd69d61fb354966190865a63e687f3bcf38afb6408aebc5d5d8f651341f379b8023c32bcfe9440e86379a540bbdb1eb7d9dc3ed604a26c3352019c62
MISC metadata.xml 398 BLAKE2B 0c2320063cc47c8a993ed456ac3a68466ce443b910d43739552d0f365dd178ed59ff76b2e23bab38b1962b9ce8cc973c03125096074a8bc33b09c8789ef236a5 SHA512 6599412f7feebc12c72eba06522563ff16d700e953d6ebc54f88544e49ad5e48e265b939a4fcfd788776abfb03110a8a27800dee71f031ae27eb207a8f924451
diff --git a/dev-libs/libixion/libixion-0.19.0.ebuild b/dev-libs/libixion/libixion-0.19.0.ebuild
new file mode 100644
index 000000000000..132df8788b1d
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.19.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-single-r1
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/3.0"
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ MDDS_SLOT="1/2.1"
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.18" # based on SONAME of libixion.so
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-util/mdds:${MDDS_SLOT}
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
+ $(use_enable python)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 274322f24718..ec4bffd84edf 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/2.1"
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
else
- MDDS_SLOT="1/2.0"
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.18" # based on SONAME of libixion.so
+SLOT="0/0.20" # based on SONAME of libixion.so
IUSE="debug python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"