summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 15:53:45 +0000
commit83ebb477861172671f6796999e016400b659d65f (patch)
tree0cec26d10b5fcfee34cd56a952e8111f306feefb /dev-libs/libixion
parentbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (diff)
gentoo auto-resync : 25:02:2023 - 15:53:45
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest3
-rw-r--r--dev-libs/libixion/libixion-0.17.0-r1.ebuild57
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild9
3 files changed, 63 insertions, 6 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 748f800bb36e..2077a80328ea 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,4 +1,5 @@
DIST libixion-0.17.0.tar.xz 499836 BLAKE2B c8c31b07ad14dd49be259686af3e39e6f5d4aeeb8680030ea7bd2697c8baa72123f2659b3087f224f956612dc444c97e6a6d331fd3deff780981bab4d5b6ad25 SHA512 0acdb2eae5250236a94b1a3344ca990058ea8db7b1e741545bcb7160f9e28d21a3c2ec336621fd590df10188a4d5feadfbb3a63f57e9bfd2cc1bffc04009ffad
+EBUILD libixion-0.17.0-r1.ebuild 1167 BLAKE2B 6dc22802e6d6d7905c167e99dec5da1931cb446adbc8a2dd743380d24e81973046d31595fb556163bfaf9a8c33c755dbe34edd2d67ee15d1e009f16577fcb82e SHA512 0aab9d28c2c9c45208ce6b474d1edfebaa69c2721cc8ce15fad07600bf0a8838099d9ec44786623088acaabf80a3bead4d2e05ca492b4c74803971e949fccefb
EBUILD libixion-0.17.0.ebuild 1162 BLAKE2B e2d421e79a2a9d0c54f4edc1f382d6f8dbb216a1c3df2a77be3b50f09ff8ea1f77115a3c68870436780af7ecc7b9e5fd95b9b73b8464f646ece59dd35e9c5bf0 SHA512 950fab7a0dc0504a816bff4badb4509c6e05eb809121bfc288bde06a2384faf7956b6277f89abdc25f5b40b20f12af26eed0885a688172f09306b3b6b345dce8
-EBUILD libixion-9999.ebuild 1166 BLAKE2B 6e3f909b0f5564503eae43d623aab82d8b1b25df9796f2105db4a9f969b569f3d84493c8607c405e318ca550ced46bcc6c6300ce7dfc14273fe8fbe8c2edcd24 SHA512 5670f336e899041e11341f928394af2e0f760371bd0b1d54edb201e5328516bace9e8b0585b2222dc4b57238d79f709699484c5a383b2d4b710859cd68f2ce81
+EBUILD libixion-9999.ebuild 1166 BLAKE2B 1d2ab3ad274add875cb87b50ca8d9c8d07dc1ba12fcbad5337a7bbe00fc919ac3f0bf441d9f653d528f314f5b4d1909e5a81f6c553e55b0cb60aecc2c427f736 SHA512 f1b6fdf21ee1641fbe04bb8278e834b1c9d237341cf91dc8f737d18853f07da0dbeef179e400bf1983538f57ae126f647bdc4b05a49e0137fb2695414d1d3a6a
MISC metadata.xml 398 BLAKE2B 0c2320063cc47c8a993ed456ac3a68466ce443b910d43739552d0f365dd178ed59ff76b2e23bab38b1962b9ce8cc973c03125096074a8bc33b09c8789ef236a5 SHA512 6599412f7feebc12c72eba06522563ff16d700e953d6ebc54f88544e49ad5e48e265b939a4fcfd788776abfb03110a8a27800dee71f031ae27eb207a8f924451
diff --git a/dev-libs/libixion/libixion-0.17.0-r1.ebuild b/dev-libs/libixion/libixion-0.17.0-r1.ebuild
new file mode 100644
index 000000000000..fa8b08196511
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.17.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-single-r1
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/9999"
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ MDDS_SLOT="1/2.0"
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.17" # based on SONAME of libixion.so
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-util/mdds:${MDDS_SLOT}
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug debug-utils)
+ $(use_enable debug log-debug)
+ $(use_enable python)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index bdf365c4dc51..274322f24718 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -3,15 +3,14 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
-if [[ ${PV} == *9999 ]]; then
- MDDS_SLOT="1/9999"
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/2.1"
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
else
@@ -39,7 +38,7 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {