summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libixion
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest4
-rw-r--r--dev-libs/libixion/libixion-0.13.0.ebuild54
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild54
-rw-r--r--dev-libs/libixion/metadata.xml14
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
new file mode 100644
index 000000000000..845ae110702e
--- /dev/null
+++ b/dev-libs/libixion/Manifest
@@ -0,0 +1,4 @@
+DIST libixion-0.13.0.tar.xz 413756 BLAKE2B 04aef61a1cc691bb159d7e8131e2e47fe2590634adc93f2e5771ed106316eb1c92ee7c4aa05ba753a1751cb5e7c55cba9263515671a26f9bc9983a1cfcacceff SHA512 15784e947164d106e677c59ece53b3cd401d4f9433cc5331a35d3be8332ae4f20a469ca73b30b253433c86da4afde886dfb4ac23e46ed46376a7349e0276c3a0
+EBUILD libixion-0.13.0.ebuild 1148 BLAKE2B be4a403e157a7d39a5e0e4828250bd738dc817af41a4c49c6a2198ee0095d6714f9403248559462bfd295552d300e7f8d2c385f60ceab29071d6ab33d4016931 SHA512 c5adfd22bf54af99c81df60a96832615e98441bc8575e0202b7e32027cb6b3e4bf695b483364519851764d753fe84c4c97eea935ad5fc0d827f83942c67f6827
+EBUILD libixion-9999.ebuild 1150 BLAKE2B d4d57ba89107e6a3c81ce172ec28a10cf11b133e1423862160ac587fe2de19aca6e216fb8bbfba5620b905856ffcfb73431b15aa9d4af1c31e1fe63145ff4c4d SHA512 46d1e9174374413fa3a9bec611d202420efbfe3e1d6da0da3772775d6a486739cfcc0177c0bf76c13f3a8bc983584a81e3b32c83dd8db102aa67755470d989a5
+MISC metadata.xml 397 BLAKE2B f586541f39dbba914dbeac46a03879649b394183dc117093dd1cac33d506dfb5cd0193a322761c3aebe5801a9851cfebc674e2487c86f03a5f6a53fdac059876 SHA512 558a3f9911ec5f5404e709f634595a4001adab07488e9da379b4936fd4d6742e40490aa1290f2e88716d2e5732462b1d63d52b8cdea4c58c77e1fbff17439312
diff --git a/dev-libs/libixion/libixion-0.13.0.ebuild b/dev-libs/libixion/libixion-0.13.0.ebuild
new file mode 100644
index 000000000000..ba41158d8f25
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.13.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.13" # based on SONAME of libixion.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
+IUSE="debug python static-libs +threads"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.0:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
new file mode 100644
index 000000000000..7fed246e3057
--- /dev/null
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.13" # based on SONAME of libixion.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug python static-libs +threads"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.0:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libixion/metadata.xml b/dev-libs/libixion/metadata.xml
new file mode 100644
index 000000000000..07e60cced834
--- /dev/null
+++ b/dev-libs/libixion/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+ <slots>
+ <subslots>libixion soname version</subslots>
+ </slots>
+ <upstream>
+ <remote-id type="gitlab">ixion/ixion</remote-id>
+ </upstream>
+</pkgmetadata>