summaryrefslogtreecommitdiff
path: root/dev-libs/libixion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /dev-libs/libixion
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest4
-rw-r--r--dev-libs/libixion/libixion-0.14.0.ebuild55
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild6
3 files changed, 61 insertions, 4 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 845ae110702e..7857fa6741e6 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,4 +1,6 @@
DIST libixion-0.13.0.tar.xz 413756 BLAKE2B 04aef61a1cc691bb159d7e8131e2e47fe2590634adc93f2e5771ed106316eb1c92ee7c4aa05ba753a1751cb5e7c55cba9263515671a26f9bc9983a1cfcacceff SHA512 15784e947164d106e677c59ece53b3cd401d4f9433cc5331a35d3be8332ae4f20a469ca73b30b253433c86da4afde886dfb4ac23e46ed46376a7349e0276c3a0
+DIST libixion-0.14.0.tar.xz 427100 BLAKE2B 8f766a61d2dab2c1cd40fbd72bb3d0cad2dda1a9d4617f1bc5289237b29e8b4edab333819b3ca61dfbd9a9b22b2e5a956d5c12b0a9eab8f794cbd87a20237b4e SHA512 8681912fb1bebb4de1fdcb4f0589aa84a3e38cd21747c81a204a87594f67879732461f3c02b70d0bf5659af59c1af1fa17df425eba5946d22a8599bc8da9fd92
EBUILD libixion-0.13.0.ebuild 1148 BLAKE2B be4a403e157a7d39a5e0e4828250bd738dc817af41a4c49c6a2198ee0095d6714f9403248559462bfd295552d300e7f8d2c385f60ceab29071d6ab33d4016931 SHA512 c5adfd22bf54af99c81df60a96832615e98441bc8575e0202b7e32027cb6b3e4bf695b483364519851764d753fe84c4c97eea935ad5fc0d827f83942c67f6827
-EBUILD libixion-9999.ebuild 1150 BLAKE2B d4d57ba89107e6a3c81ce172ec28a10cf11b133e1423862160ac587fe2de19aca6e216fb8bbfba5620b905856ffcfb73431b15aa9d4af1c31e1fe63145ff4c4d SHA512 46d1e9174374413fa3a9bec611d202420efbfe3e1d6da0da3772775d6a486739cfcc0177c0bf76c13f3a8bc983584a81e3b32c83dd8db102aa67755470d989a5
+EBUILD libixion-0.14.0.ebuild 1164 BLAKE2B 1275494a8edcc72ffd850eb78711f4a69e77f9184ab8fbc648d3cd7fc412d12853ea105c8e7e7df50c2b5dbdee6884f95feca333d7a10d468f6e8d6c3db64f11 SHA512 ef9a464b6efd6e0d7fb3971c86939db24c9f48d54f3c7b33922f49b9913b34f5c63b21525ec317cf59b5d9af7ee43a2c8e316037a2132e0f4e940a8158c2c142
+EBUILD libixion-9999.ebuild 1150 BLAKE2B 38594e3d79ea10b4203f3d7ee9cda5fa981344902e184be7001488c800abdf425776f9e38758218aecf617fa297f8cea6e80ce1f8c2a6275ebbcd1523e8ea861 SHA512 3a237abfa6be00e21902f39be0bd78c355393e8005749d13898f4a3eba1652ba995014a4e9e8e2cb1d4c124b4747a3707eb55920afbec748c8becd1f0985dd77
MISC metadata.xml 397 BLAKE2B f586541f39dbba914dbeac46a03879649b394183dc117093dd1cac33d506dfb5cd0193a322761c3aebe5801a9851cfebc674e2487c86f03a5f6a53fdac059876 SHA512 558a3f9911ec5f5404e709f634595a4001adab07488e9da379b4936fd4d6742e40490aa1290f2e88716d2e5732462b1d63d52b8cdea4c58c77e1fbff17439312
diff --git a/dev-libs/libixion/libixion-0.14.0.ebuild b/dev-libs/libixion/libixion-0.14.0.ebuild
new file mode 100644
index 000000000000..51e6e3935b81
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.14.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.14" # based on SONAME of libixion.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug python static-libs +threads"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.4.1:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 7fed246e3057..9dbcab360b8f 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.13" # based on SONAME of libixion.so
+SLOT="0/0.15" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="debug python static-libs +threads"
@@ -26,7 +26,7 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-1.2.0:1=
+ >=dev-util/mdds-1.4.1:1=
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"