summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-19 05:58:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-19 05:58:32 +0000
commite1d95cd8c0944013a250bde528253138bffa2e65 (patch)
tree08cbcfc886960c44d0c296e7144f9fd430b3a838 /dev-libs/libinput
parentd39fec05a2fac9978cd77634744637509744b561 (diff)
gentoo auto-resync : 19:01:2023 - 05:58:31
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.22.1.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 86e9d849043e..abc41105d882 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,5 +1,7 @@
DIST libinput-1.21.0.tar.gz 988650 BLAKE2B 54c63beeff8dee93a52774220b45321d8a94261687b463319fbae9246331b532be7995a5b32c30425b9d0708b2ba69d4b4e83e8dc7ecebe6fb1237b723a266b6 SHA512 510273d68f2d4cfa61564a706b1f334f6bfca0d1c8faf0bb8aa656cf3fbd5e38d79d6fbaa01a20d38bc15777c9afc341e4ed08d35ef367ef3803ce788cbc4a0e
DIST libinput-1.22.0.tar.bz2 796133 BLAKE2B 3552f0a9ab0690969c5a7d62882733aa7bcaed1c0e97ff3606f58558c235cb67e3c81bc5a277273d26e6847438acccfc942d2fbec312e9a0d121d8ea21896496 SHA512 62cc36845daa7bc4b8477dd71abe629309683a93de753382a90e8466915e2b96b9c6914b431747d3462c15d8ab42bc70ee755800eec60c4ad7e9f3b4f7dba76d
+DIST libinput-1.22.1.tar.bz2 794829 BLAKE2B 253f840e45ab2293503a0da09ea914b982e643c35928af6762955325a002b5bf20bf8571e705e3a050663cd0e1e26ee0cf4952a6193659f9b27ad1080008e900 SHA512 9d1985bc03ae304643fcd3acb762afc53305942e39071a062e7f8950be4929c72bdfeff06039c77f70e53233885df1e2e1a1dc538caeefd2b46f35826d290e9e
EBUILD libinput-1.21.0-r1.ebuild 2289 BLAKE2B 67343071c46f9524b95e42627c1ddee44d48185ecb8b6d4ba8d29be14b9cdc49d1551014b8560618811f39f8201e826ad6c582dc7abf932610ea3b4c63d1fbfa SHA512 df6565f7e5b581a5c68c2158b62369477cf4bbf1ee12d87bd00f38188fac9a47b98958cb3b5a582d8972ca91bf4a06a96d69a60d1230e4d3d3cb49c94119c160
EBUILD libinput-1.22.0.ebuild 2179 BLAKE2B 7f0b6c8b324998c1163b669cdba8f8debceb1f8f5ba170e719b7c2d575863e9651ce2ab5e00e68997f2a959b0df05292ae8430790f64be15953239844a1809e6 SHA512 de0af78b1db94dca1b113294a0f5d117fb8dabc190bc6dc16a6fccde387a493337bb6bb367564dbce9708b66250da23d3bd7a1ae6d6c911967da3449ad5db11a
+EBUILD libinput-1.22.1.ebuild 2179 BLAKE2B 7f0b6c8b324998c1163b669cdba8f8debceb1f8f5ba170e719b7c2d575863e9651ce2ab5e00e68997f2a959b0df05292ae8430790f64be15953239844a1809e6 SHA512 de0af78b1db94dca1b113294a0f5d117fb8dabc190bc6dc16a6fccde387a493337bb6bb367564dbce9708b66250da23d3bd7a1ae6d6c911967da3449ad5db11a
MISC metadata.xml 339 BLAKE2B c649f0ffaad1b1dc76c3d3184d95356b2925f642ff6b96c3eba0c31a1d96c3d9b741c1348f8ec90d02428c30a836872fe4e42e7ab5f5e5197f4a787f9147a1a8 SHA512 e9aeca6cc4451ab5b622f597f8debaecfdc672244e5e0b687ac294c20009ba42fb2ccc45e7016a2427312e1c768259005e0a7ff53026087570382652ec23cb60
diff --git a/dev-libs/libinput/libinput-1.22.1.ebuild b/dev-libs/libinput/libinput-1.22.1.ebuild
new file mode 100644
index 000000000000..a6741dc43f7b
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.22.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2014-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit meson optfeature python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/10"
+if [[ $(ver_cut 3) -lt 900 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.27:= )
+ >=dev-libs/libevdev-1.9.902
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+
+python_check_deps() {
+ python_has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ python_has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ python_has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ optfeature "measure and replay tools" dev-python/python-libevdev
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}