summaryrefslogtreecommitdiff
path: root/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libindicator/libindicator-12.10.1-r301.ebuild')
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r301.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
new file mode 100644
index 000000000000..e4478c886b84
--- /dev/null
+++ b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils flag-o-matic virtualx multilib-minimal
+
+DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
+HOMEPAGE="https://launchpad.net/libindicator"
+SRC_URI="https://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( dev-util/dbus-test-runner )"
+
+src_prepare() {
+ # https://bugs.launchpad.net/libindicator/+bug/1502925
+ epatch "${FILESDIR}"/${PN}-ldflags-spacing.patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-flags -Wno-error
+
+ myconf=(
+ --disable-silent-rules
+ --disable-static
+ --with-gtk=3
+ )
+ local ECONF_SOURCE=${S}
+ econf "${myconf[@]}"
+}
+
+multilib_src_test() {
+ Xemake check #391179
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}