summaryrefslogtreecommitdiff
path: root/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-libs/libindicator/libindicator-12.10.1-r301.ebuild')
-rw-r--r--dev-libs/libindicator/libindicator-12.10.1-r301.ebuild40
1 files changed, 26 insertions, 14 deletions
diff --git a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
index 068768b22c0f..a56e52859f3f 100644
--- a/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
+++ b/dev-libs/libindicator/libindicator-12.10.1-r301.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils flag-o-matic ltprune virtualx multilib-minimal
+EAPI=7
+
+inherit autotools flag-o-matic virtualx multilib-minimal
DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
HOMEPAGE="https://launchpad.net/libindicator"
@@ -14,32 +15,42 @@ KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND=">=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
- >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
+RDEPEND="
+ >=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
test? ( dev-util/dbus-test-runner )"
+PATCHES=(
+ # Fixed version of https://bugs.launchpad.net/libindicator/+bug/1502925
+ "${FILESDIR}"/${PN}-12.10.1-nonbash.patch
+ "${FILESDIR}"/${PN}-12.10.1-no-werror.patch
+)
+
src_prepare() {
- # https://bugs.launchpad.net/libindicator/+bug/1502925
- epatch "${FILESDIR}"/${PN}-ldflags-spacing.patch
+ default
+
eautoreconf
}
multilib_src_configure() {
append-flags -Wno-error
- myconf=(
+ local myconf=(
--disable-static
--with-gtk=3
)
- local ECONF_SOURCE=${S}
- econf "${myconf[@]}"
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
}
multilib_src_test() {
- Xemake check #391179
+ # bug #391179
+ virtx emake
}
multilib_src_install() {
@@ -47,6 +58,7 @@ multilib_src_install() {
}
multilib_src_install_all() {
- einstalldocs
- prune_libtool_files --all
+ default
+
+ find "${ED}" -name '*.la' -delete || die
}