summaryrefslogtreecommitdiff
path: root/dev-libs/libgweather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
commit6c169675dd21d25ad82ab0560f3d5b1e714219b6 (patch)
treeed786201c471d4535a5eca3a754866a856812bcb /dev-libs/libgweather
parent7fe6984499f95d52b3c32af6ab771aa8f08c2dd4 (diff)
gentoo auto-resync : 23:03:2024 - 01:00:42
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest2
-rw-r--r--dev-libs/libgweather/libgweather-4.4.2.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index ae52e88512fb..f0c6df264fd6 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1,3 +1,5 @@
DIST libgweather-4.4.0.tar.xz 2808680 BLAKE2B d3bfabd7936a5dc5f6f77cbb5acb3a7b80cebe1f08ff48582e1609cad04051ce8b84959c27576c928233e4625db8831c99d049378908cbe562b48221b6f37392 SHA512 dd232d36b168132a7c7cf06ffff16e88eb6e3e9e003e39b975df3d294ada401ab7d34de386dcc53452de6b0f8c68ff7f0cf6a94492e353828e00d4a1204b5d00
+DIST libgweather-4.4.2.tar.xz 2827456 BLAKE2B de53257f15b5b0e38bd41ccf69665e701065db85d144853831f409cd1a7116482bb374a858b022f9fb5eb167203bb393fa4a9087ab2c2272ba1b83dec3efcbb0 SHA512 66012af9bc50dfbb8cdb3d8b1ad7c72b5e8e012d8bbaa5a8d7a841f4bd5b2ebe0a490cc7ea256ea5e1d218f328da8826fb2345aa848fd961da271e64cdf330ad
EBUILD libgweather-4.4.0.ebuild 1972 BLAKE2B 6cce4d6a1cba8577eeda498450550e88c51df2a1620299dfc769f8860afec0ed23c4da9e4b28219122b1ec2801a830c3e6cc0a1d84a304878397e084bbf766ca SHA512 176ba510adf1b7550f217cfd030d7ecfed4f4930c10093b977ef89563342241bceeb54a02f6e44db98f19cc059d9a1b37cbdcec61d48653be6b05f930c01b8d3
+EBUILD libgweather-4.4.2.ebuild 1975 BLAKE2B f406f0819ca0ebf2793f82b0e4abacacae5b6fd1d013d8dc475f5d663f26bd6ec61ea01b06f3ea8d327993ae5d345902fb443f623bae516f90971e3421549cc9 SHA512 2e72d73b02541c62f0555922f94f486f1022622733e83faa132a07e32dcd731b54ded1e11ae4f0fa2374fc4d691e0672462f1a58889900106ad51dd1d896c02d
MISC metadata.xml 352 BLAKE2B 3726dfdf7269138db7992dbab72db960ed2362a8c753362376f28fa37e0849ef89f74b132dea4c63120dfb777f27566aea12f5dc92ddbeeb5a3b8139d4feeb9c SHA512 06dcfdd1ba301e34b2b9a23f3cdb5a686daa8fcc7a2caa8ac921eade3e805589ba2bb148da5f64f95f93d62dda71b5e19f37b33f1e35201c61bd8e0bb996bbf4
diff --git a/dev-libs/libgweather/libgweather-4.4.2.ebuild b/dev-libs/libgweather/libgweather-4.4.2.ebuild
new file mode 100644
index 000000000000..1ff7ca20d5d4
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-4.4.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="4/4-0" # subslot = 4-(libgweather-4 soname suffix)
+
+IUSE="gtk-doc +introspection test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ vala? ( introspection )
+ gtk-doc? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=net-libs/libsoup-2.99.2:3.0
+ sci-geosciences/geocode-glib:2
+ >=dev-libs/libxml2-2.6.0:2
+ dev-libs/json-glib
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ vala? ( $(vala_depend) )
+"
+
+python_check_deps() {
+ python_has_version -b "dev-python/pygobject[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+ use vala && vala_setup
+ # The metar test requires network access
+ if has network-sandbox ${FEATURES}; then
+ sed -i -e '/metar/d' libgweather/tests/meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libgweather-4.0 "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}