summaryrefslogtreecommitdiff
path: root/dev-libs/libgusb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libgusb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libgusb')
-rw-r--r--dev-libs/libgusb/Manifest3
-rw-r--r--dev-libs/libgusb/libgusb-0.2.11.ebuild54
-rw-r--r--dev-libs/libgusb/metadata.xml11
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libgusb/Manifest b/dev-libs/libgusb/Manifest
new file mode 100644
index 000000000000..59159a2d71b0
--- /dev/null
+++ b/dev-libs/libgusb/Manifest
@@ -0,0 +1,3 @@
+DIST libgusb-0.2.11.tar.xz 291992 BLAKE2B f43065fac0fcfbc3e392b90dc05537746ce1325d623161e93e1a306b87b07012ef4e11242514cd3da0b83a7df6adc052e20fd3336b53d2543ed9e23886a776f5 SHA512 f9c3c204b5f0feaf706b23dd9a174feb36a9f3c8db8ffb5dcdefa66b18ba0ac963c6041d2d91a6a2f6e23036fc6486d142210bd5348e10c026a6defeb0bee096
+EBUILD libgusb-0.2.11.ebuild 1277 BLAKE2B abaaea67c8cb2b7deee771b4f929a4e30ea472fdbf7e7382cb8cb73859e4ab87ba448e6f230ec057b3ba031128755336c7fd083f212efee8bb17210428579fc8 SHA512 1403402b5ecf3f369429f2b34b2f26490569c393b3f37dfc47a193430b289a74f9127179e1bda111c2eb4b1ac2eb177eb1345af15b7880ee3ae60c329f072246
+MISC metadata.xml 343 BLAKE2B 5905d49c021f1b8d8e5167415d0f0c731c0b204fad7aa73f10f6a7dc8b8f417e9591ed26ce655e2d5e5963e84f0ce44d77e59cd79e8d1921899b0a9627d52911 SHA512 096d78e0613e0475d5499f3c30542bd22fc98a2598a7e2e5719747a809a19288a0a36897bc9bc647fceb98f3579f7148c32d16d78c6114d0b925f143daca91bc
diff --git a/dev-libs/libgusb/libgusb-0.2.11.ebuild b/dev-libs/libgusb/libgusb-0.2.11.ebuild
new file mode 100644
index 000000000000..06c454aa1ae5
--- /dev/null
+++ b/dev-libs/libgusb/libgusb-0.2.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 multilib-minimal vala
+
+DESCRIPTION="GObject wrapper for libusb"
+HOMEPAGE="https://github.com/hughsie/libgusb"
+SRC_URI="https://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+
+IUSE="+introspection static-libs vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2[${MULTILIB_USEDEP}]
+ virtual/libusb:1[udev,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ vala? ( $(vala_depend) )
+"
+
+# Tests try to access usb devices in /dev
+RESTRICT="test"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable vala)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/api/html docs/api/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/libgusb/metadata.xml b/dev-libs/libgusb/metadata.xml
new file mode 100644
index 000000000000..2c138c7560a0
--- /dev/null
+++ b/dev-libs/libgusb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hughsie/libgusb</remote-id>
+ </upstream>
+</pkgmetadata>