summaryrefslogtreecommitdiff
path: root/dev-libs/libgpiod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-libs/libgpiod
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-libs/libgpiod')
-rw-r--r--dev-libs/libgpiod/Manifest2
-rw-r--r--dev-libs/libgpiod/libgpiod-1.4.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 4200edb85652..3bfc66b50326 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1,3 +1,5 @@
DIST libgpiod-1.1.1.tar.xz 302672 BLAKE2B 71c624f923118b7c50970beb737f2c813d1470a34f95798f9ce821211e16f15e2a3fd42d0054e25529ddc9846725c0935d915784f22d2509b844a0bac61b66b6 SHA512 a1d902ce8e1c94d5550ade2fb4889ebe28b86523505b92ab907f58c8e6903eaf07ce16278126989462956b879f591b42ddd50fbc4537c1b5af459f23a4dfc12f
+DIST libgpiod-1.4.1.tar.xz 314936 BLAKE2B 8949c4a96f69a83a479f5951e6f1eb8fee56db700e72320131c365a5d736a48700fb42b7ecc2b676cec54887eaa650075f45ec1f0b803de914958cefd3863db8 SHA512 2a9c58a46fb3c2e2dd15cc4ba52f589b44e5ae4547226eeb68a8e5bea6292d38aaf0889cc639e0979e12e129bb944bb42d9258f10292f59d074660e7c2d56d04
EBUILD libgpiod-1.1.1.ebuild 755 BLAKE2B bfdfa328997d74ebc185549bedc6c8311d05904141a123e1aa7d1e701d10e0cb18d308fb196ef01ad6d2a8db4b82bb196bc1776a16f6135edc94b0975b0eb972 SHA512 9055950c40a6878e36082387dd6ddcd460ad8c0fe14cc258f391d68e555244c74493441ae845a81a6d1c707ea950063478a4408cd8f6be323fa5decfa9bd3b52
+EBUILD libgpiod-1.4.1.ebuild 1151 BLAKE2B 403ba368c1f61f9067c490056542fc5780650d2f42a3b63f00295602c8d2d2273cc850ed017516ed998a70581becceadce6f314c63ba60b979d83da3f07c3545 SHA512 8e8575bf37c2849469eb35ed7d096682bd278863f7f3ce4c21b6e5d3b8a2877090c246a1367d90db883bd1c6ab77066dd0a97e0956a952512525ec2f1c699613
MISC metadata.xml 343 BLAKE2B fc70cc41ae2770c509013c4d1a5d8aaa441b6d52d1259b9e2f5cb2e8928e146f5451e399d1345901e88b1b488095990e8c9f9b296b43b38f91b38a22b3507c90 SHA512 051b47fa59f992bf8347e89d17eecf645d4a20457ac1d9db931982c9efa4a61d777df4e215a790d518ac77b2baa7497862fc724fbd581dccfa404bfd232d749b
diff --git a/dev-libs/libgpiod/libgpiod-1.4.1.ebuild b/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
new file mode 100644
index 000000000000..50141fbb2619
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs +tools cxx python test"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(multilib_native_use_enable python bindings-python)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ --disable-tools
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+}