summaryrefslogtreecommitdiff
path: root/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
commitae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (patch)
tree63845e7d405c04516103b1cee33911cea9a63b0e /dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
parent2cb26483945211e812d7a0351ae472a676cd9592 (diff)
gentoo auto-resync : 16:08:2022 - 20:31:05
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
new file mode 100644
index 000000000000..83669f2db358
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="static-libs +tools cxx python test"
+RESTRICT="!test? ( test )"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+
+pkg_setup() {
+ CONFIG_CHECK="~GPIO_CDEV_V1"
+ linux-info_pkg_setup
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(multilib_native_use_enable python bindings-python)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ --disable-tools
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+}