summaryrefslogtreecommitdiff
path: root/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
commitb8c48743664466ac0f638f0949fd78bfb9f5eae6 (patch)
treedd60615a286df950811f8267c0631e1fd97eac58 /dev-libs/libgpiod/libgpiod-1.4.1.ebuild
parentcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (diff)
gentoo auto-resync : 25:10:2022 - 15:53:58
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-1.4.1.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.4.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.4.1.ebuild b/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
deleted file mode 100644
index 5d51f888fe65..000000000000
--- a/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal
-
-DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
-HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
-SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-# Reflects the ABI of libgpiod.so
-SLOT="0/1"
-KEYWORDS="amd64 arm arm64 ~riscv x86"
-IUSE="static-libs +tools cxx python test"
-RESTRICT="!test? ( test )"
-
-# --enable-tests enable libgpiod tests [default=no]
-# --enable-bindings-cxx enable C++ bindings [default=no]
-# --enable-bindings-python
-
-multilib_src_configure() {
- local myconf=(
- $(use_enable tools)
- $(use_enable cxx bindings-cxx)
- $(use_enable test tests)
- $(multilib_native_use_enable python bindings-python)
- )
-
- if ! multilib_is_native_abi; then
- myconf+=(
- --disable-tools
- )
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-multilib_src_install() {
- default
-
- find "${D}" -name '*.la' -type f -delete || die
-
- if ! use static-libs; then
- find "${D}" -name "*.a" -delete || die
- fi
-}