summaryrefslogtreecommitdiff
path: root/dev-libs/libgdata/libgdata-0.17.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libgdata/libgdata-0.17.9-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libgdata/libgdata-0.17.9-r1.ebuild')
-rw-r--r--dev-libs/libgdata/libgdata-0.17.9-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libgdata/libgdata-0.17.9-r1.ebuild b/dev-libs/libgdata/libgdata-0.17.9-r1.ebuild
new file mode 100644
index 000000000000..11e9b54b1f4c
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.9-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+
+IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
+REQUIRED_USE="
+ gnome-online-accounts? ( crypt )
+ vala? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.55.90:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ crypt? ( app-crypt/gcr:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:=[introspection?,vala?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( >=net-libs/uhttpmock-0.5 )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.17.8-disable-demos.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-build-demos \
+ $(use_enable crypt gnome) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test always-build-tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ dbus-run-session emake check
+}