summaryrefslogtreecommitdiff
path: root/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild')
-rw-r--r--dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild b/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
new file mode 100644
index 000000000000..f4d6bb2c005f
--- /dev/null
+++ b/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Make fuzzy comparisons of strings and byte arrays"
+HOMEPAGE="http://fstrcmp.sourceforge.net/"
+
+LICENSE="GPL-3+"
+IUSE="doc test"
+SLOT="0"
+
+SRC_URI="http://fstrcmp.sourceforge.net/fstrcmp-0.7.D001.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fstrcmp-0.7.D001"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ doc? ( app-text/ghostscript-gpl )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake all-bin
+ use doc && emake all-doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-bin install-include install-libdir install-man
+ use doc && emake DESTDIR="${D}" install-doc
+ einstalldocs
+}